Time Machine Not Backing Up

Hello,

I'm in OSX

I deleted the backups of my time machine. I'm using an external drive.

Now time machine won't back up.

What do I do?

Thanks.

Let me know what information you need,.
LVL 7
weikelbobAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Chris MillardCommented:
Have you tried re-adding the drive in Time Machine preferences?
0
Eoin OSullivanConsultantCommented:
Can you clarify what you mean by "deleting the backups of your time machine"?

Did you open the time machine backup folder on the external drive and manually deleted certain folders?   If this is  what you did, in effect you may have damaged the integrity of the whole time machine backup system.  You are not supposed to ever manually delete any files or folders from Time Machine backup drive without using the Time Machine interface itself.

You should open the Console application and see what errors Time Machine is generating when you try and run the backup .. or you can also use this free application
http://www.carnationsoftware.com/TM_Error_Log_WebPage.html

If you can post the error message from Console or TM Error Logger we may be able to provide more detail.
0
strungCommented:
If by deleting, you meant reformatting the drive, you have to reformat it as Apple Extended Format (Journalled), then re-select the drive in the Time Machine preferences.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

weikelbobAuthor Commented:
Sorry for the delay

When I go to

Time Machine -> Options

An "Exclude these items from backup" comes up with my old backups in grey (It says "Time Machine Backups"). I can't do anything with them. There's 495GB worth on a 500GB disk. The new backups are working but I only show 5GB available.

What do I do?
0
Eoin OSullivanConsultantCommented:
If you're referring to the Time Machine Panel in System Preferences and the Options button on the bottom right of the panel .. you are not using the Exclude Items correctly.

That option is designed to allow you to EXCLUDE folders and files on your Hard Drive from being backed up to the external HD .. you cannot and should not be adding any folders from the externalHD to this dialog.  You should use the MINUS - button to delete any folders which are listed on the exclude list and are on the TimeMachine backup HD itself as it is not relevant.

When TimeMachine runs it will look at the excluded items and exclude them from the files on your HD to be backed up.
Once TimeMachine runs out of space on the external HD it will AUTOMATICALLY delete your oldest backups to free up space so you can continue to backup .. so you don't need to manually do any cleanup.

If you're trying to free up space on the external HD you need to open the HD itself in the Finder .. you should see a folder called Backups.backupdb
Inside that folder will be a folder for each unique computer which uses that external HD for backups .. normally there is just one folder for your current computer .. if there are other folders listed for computers you no longer have or backup you may delete these but be careful to only delete unused ones.
Inside the folder named after your computer you'll see lots of folders with date & time stamps .. NEVER EVER EVER delete any of these as this will completely break your TimeMachine backup system.
0
weikelbobAuthor Commented:
I went to my finder and hard drive and there's not much there. It looks like it may have been deleted. How do I find out if it's been deleted the wrong way and what do I replace/do if that is the case?
0
Eoin OSullivanConsultantCommented:
Its quite hard to diagnose this without screenshots .. can you give us screenshots of the folder structure on the external Hard Drive?  If you put the folders in the trash .. you may be able to restore them to their previous location
0
weikelbobAuthor Commented:
They're in my trash. When I say "Put Back" there's already a folder there so it won't do it. There's a new folder trying to make backups. Does that help? Screenshots are easy for me if you still need them.
0
Eoin OSullivanConsultantCommented:
It sounds like time machine is messed up and you may not be able to repair it.
If you tried to empty the trash at any time since you put the backups in the trash the problem will be worse.

First thing is to Turn off  time machine in the system preferences.  
Try the put back option on all the dated folders which were inside the backup folder with the name of the pc you're using which are now in the trash. If put back won't work you can try manually dragging the folders from the trash to the correct location.
The final option is to use the terminal to run Unix commands to move the files back but I'll wait to see if either if the first two simple options works .

If that fails you' may have to accept that the current backup is damaged beyond repair and you may have to start a new time machine backup on the external drive.
0
weikelbobAuthor Commented:
It says, "The operation cannot be completed because the backup items cannot be modified". When I try to drag, and it won't let me do the "put back" either.
0
weikelbobAuthor Commented:
How do I do this in the Unix terminal?
0
Eoin OSullivanConsultantCommented:
You can TRY to run the mv command as a super user (sudo) on the hidden trash folder on the external hd.

cd /Volumes/EXTERNALHD/.Trashes
sudo ls -al
sudo mv [backup folder in trash] [TimeMachine Backup folder on External]
replace the text in brackets with the correct path values

You need to only copy the dated folders from inside the trash and ensure that a folder with the same name doesn't still reside on the TimeMachine.

To be honest .. it is very difficult to restore these backups if you've put more than one dated backups in the trash.  If you have multiple backups sent to the Trash I'm afraid you'll have to start again with Time Machine.
The simplest solution is to use Disk Utility to reformat the external HD (use Apple HFS file system) and then re-enable Time Machine and select the external hd.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
weikelbobAuthor Commented:
I see. A reformat is all I wanted anyways. Thanks for the help.

Bob
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.