Server 2012R2 Broadcom 1Gb NIC transfer speeds dropping to below 20Mb/sec

Hi Experts,

I have done a clean install upgrade on a Dell Poweredge R420 from Server2008R2 to Server2012R2 Hyper-V but my data transfer over the LAN is struggling.  Before the upgrade I was able to transfer at around 111Mb/sec.  Now, it will start out at around the same 111Mb/sec but after a minute or two it drops down to an average of around 15 - 20Mb/sec.  Some research has recommended updating the drivers on the Broadcom NetXtreme NICs to the latest.  I have done so but no improvement.  The only thing I can think of is that I have my 2 NICs in a teamed LAN setup.  I am thinking of unteaming them to see what the speed is like on a single NIC (in the middle of a large VHD transfer at the moment so can't try it yet).  I've also updated the PERC controllers firmware and drivers just in case.

It's definitely a software issue as I was able to transfer off the same hardware prior to the OS upgrade with no issues.  

Just to be clear I am transferring from one LAN host to another, there are no VMs involved at this point.

No AV on the host either.

Any suggestions would be very welcome.
murphygeAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tony GiangrecoCommented:
I've had the same problem in a teamed setup using a Dell 2950. After breaking the team and disabling the 2nd network adapter, it worked much better.

Hope it helps!
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Broadcom Gigabit NICs have VMQ (Virtual Machine Queues) turned on by default for all ports.

Here's why that setting needs to be disabled: Broadcom Gigabit and VMQ.

Please disable VMQ on _all_ Gigabit ports and reboot.

Things will settle down after that.
murphygeAuthor Commented:
Apologies for the delay in getting back to this question. The problem turned out to be a disk issue, despite my opening comments - after disk replacement, file transfer performance returned to normal.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
murphygeAuthor Commented:
Solution was a separate issue not part of the question.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.