SQL Server Permissions

I am new to SQL Server.

We are converting the back end of a legacy MDB to SQL Server tables.

I was successful in converting the back end data MDB to a SQL Server database using SQL Server migration assistant.
Then I linked all of the SQL tables to the Front end MDB, replacing the tables that used to be linked to Access.

All is well, except I can't revise data in any of the tables.  I have been able to add new records to the tables but no revisions.

I have tried using  VBA query as in this code:

'
updateString = " Update tblTaxRecs" & _
               " Set [Active_YN] = True " & _
               " Where [TaxYear] = 2014  " & _
               " AND  [BRT] In (Select [BRT] From tblRpt_BRTPrintList_Local ) "
'
DoCmd.SetWarnings False
DoCmd.RunSQL updateString

Open in new window


I get a runtime error 3073, Operation must use an updatetable query.

I have also tried opening the table directly by double clicking on it.  The data shows but I can't change any of it.

Is this some security or permissions  that must be set up in SQL Server or Access.
LVL 1
mlcktmguyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Deepak ChauhanSQL Server DBACommented:
Try first in SQL server by executing the command in SSMS

Update tblTaxRecs Set [Active_YN] = True
Where [TaxYear] = 2014 AND  [BRT] In (Select [BRT] From tblRpt_BRTPrintList_Local)

If you get the error like 'Update permissions was denied on the object. <tablename> , Database '<>', schema '<>'.


Grant the permission to user.

 
---grant select, insert,update and delete permissions to user on whole dbo schema
use <databasename>
go
Grant select, insert, update, delete on schema:: dbo to <username>
-- on a specific table
use <databasename>
go
Grant select, insert, update, delete on tableName to <username>
-- grant dbowner permission to user.
USE [<databasename>]
GO
EXEC sp_addrolemember N'db_owner', N'<Username>'
GO

Open in new window

Deepak ChauhanSQL Server DBACommented:
But it does not seems permission issue.

Check the tblTaxRecs table in sql server if this table doesn't have a primary key, you can't edit any of the table's fields from Access because linked to a SQL Server table

If PK not there then apply.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Gustav BrockCIOCommented:
This is most likely due to one or both of these:

1. The table has no unique primary key.

2. There is no timestamp field

For 1, add or create the qnique and primary key.
For 2, add a field of data type Timestamp to the table.
Then relink the table.

/gustav
Armen Stein - Microsoft Access MVP since 2006President, J Street TechnologyCommented:
Hi Gustav,

I don't believe the lack of a Timestamp (aka RowVersion) would cause this particular error - it can cause an error after the attempted update, but does not make a table non-updatable to begin with.

A lack of primary key is the likely issue.

Armen Stein
mlcktmguyAuthor Commented:
That was it.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Access

From novice to tech pro — start learning today.