Full Text Indexing for Exchange 2010 missing

Hi All

For some strange reason, we seem to have lost the "Microsoft Exchange Search Indexer" service from both our main OWA servers. We recently had a major power failure on our DC which dropped half the network. As a result, OWA users can't search and get "The actions couldn't be completed . . ."

I can't find the "msfte" msi or install on our Exchange DVD, or anywhere else reliable on the 'net.

I've also been through the restart server, try repair of Programs and Features, stop/start Microsoft Search (Exchange) etc.

The service still exists on a 3rd server which doubles as half of our DAG, but it's not a main HUB.

How can we reinstall the Exchange search service ?

Thanks
LVL 1
DoveSupportAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Will SzymkowskiSenior Solution ArchitectCommented:
I think you are getting mixed up. CAS does not use Search Indexing Service. This is on the Mailbox Role only. If you have a CAS role and mailbox role on the same server then you will see the search indexing service.

However if the CAS service is by itself or with CAS/HUB together you will not see the Search Indexing Service on this server. This is only for the mailbox role.

The link below outlines all of the services used by CAS.
https://technet.microsoft.com/en-us/library/bb331967(v=exchg.141).aspx

Will.
DoveSupportAuthor Commented:
Ok, so where does the CAS / OWA user get search capabilities ?  Our OWA users were able to search before the power failure, but now get the message mentioned.

Does the OWA search run from the MB servers ?
Simon Butler (Sembee)ConsultantCommented:
I would just reset the index using the built in script.
It happens so often that Microsoft provide the tool to fix it.

C:\ Program Files \ Microsoft \ Exchange Server \ V14 \ Scripts

resetsearchindex.ps1 -force -all

that will reset all indexes on all databases on the server that you run the command on.

Simon.
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

Will SzymkowskiSenior Solution ArchitectCommented:
Yes that is correct. All of the searching is done on the mailbox server when you are connected via OWA or Outlook Online mode.

If the search indexing is no longer working for some databases then you will need to use the resetsearchindex.ps1 script to correct the search indexes on the mailbox databases.

See the link below. It references Exchange 2007 but the same script is used in Exchange 2010 and also the same parameters as well.
https://technet.microsoft.com/en-us/library/aa995966(v=exchg.80).aspx

Will.
DoveSupportAuthor Commented:
Guys, I have followed the process on both MB servers and reset both IIS OWA installations. Still no ability to search from OWA . . .

Any other ideas ?
Will SzymkowskiSenior Solution ArchitectCommented:
Atfer you run this command (which should be done off hours) it will take time before Exchange has crawled the database to allow normal searching to begin. Depedning on the amount of email on each database and it you used the -force all then this could take a while. You can check this progress by going into the directory where the database is located.

From there you will see an additional folder in there, this is where the Catalog is located you should be able to see the count growing. When you use the -force all command this will also take longer as it is doing it for all databases.

I personally do not like to use this switch because all of the database are not affected so why run it for all of them? I just target the ones in question and then the process is much faster as well during the crawl.

Will.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DoveSupportAuthor Commented:
An update - I've tried redoing the command again with no luck. Am waiting for an after-hours opportunity to run again and see. Hopefully by the weekend . . .
DoveSupportAuthor Commented:
Right, ok, found the fix. After running the re-index commands, I needed to restart the services in a specific order. This helped me finish it off :-

http://clintboessen.blogspot.co.uk/2014/03/owa-search-action-couldnt-be-completed.html

Thanks for your help guys.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.