Admin rights and MS FixIt

Hello,
Last week I tried using MS FixIt and while I do have admin rights on my desktop, I could not get FixIt to work.
I got this message;
FixItMy question is; why am I getting this message if I have admin rights to my computer?  
I have windows7 64 bit.
Thank you
chimaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

McKnifeCommented:
Microsoft sometimes fail to use their own UAC feature correctly. Rightcklick the fixit and select "run as administrator".
0
chimaAuthor Commented:
McKnife, At that time, I did use the "run as administrator" and I have checked with our Sys Admin about the level of privileges I have.  What else could it be?
0
McKnifeCommented:
Please link the fixit download and I will find out soon.
0
ON-DEMAND: 10 Easy Ways to Lose a Password

Learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees in this on-demand webinar. We cover the importance of multi-factor authentication and how these solutions can better protect your business!

chimaAuthor Commented:
McKnife,  I do not have the link off hand, I could go searching.  Could we try the executable I was using.
Just change the extension from txt to exe.
If this does not work then I can go get the link.  It came from Serena Business Manager site.
MicrosoftFixit-portable.txt
0
McKnifeCommented:
Sorry, I will not run any exe. Find the link, please. What was that fixit against?
0
chimaAuthor Commented:
McKnife, I see/understand your point.  The tool does go into the registry whereby one can delete stuff.
I'll need more time to get this to you.  Hopefully by tomorrow.
0
chimaAuthor Commented:
Mcknife, here is the link; Launch the Microsoft Fix it utility from http://support.microsoft.com/mats/Program_Install_and_Uninstall
I apologize for the delay.
0
McKnifeCommented:
Downloaded and tested it on 8.1 x64 - no problems.
0
chimaAuthor Commented:
McKnife, I apologize for the delay.  I had other press tasks on my plate.
 Why then could I NOT run it on my desktop.  The Sys Admins here "at work," tell me that I have full Admin rights to my machine.
0
David Johnson, CD, MVPOwnerCommented:
You don't have an administrative token by default.. start / type cmd / right click on cmd.exe  and select run as administrator .. change to where the program is located and execute the fixit from the command prompt
0
chimaAuthor Commented:
David, I did, from windows, do a "right-click" and ran it as an administrator.  Would this be the same?
0
David Johnson, CD, MVPOwnerCommented:
no since the program launcher does not support the runas command
0
McKnifeCommented:
Make sure You are not mistaken about the admin group membership, don't rely on what others tell you.
0
chimaAuthor Commented:
McKnife, I believe you are hitting on the information/knowledge I am seeking.  Please explain "admin group membership?"  I am told that I have full admin rights on my machine, yet I run into problems, like I mention here.
I'll close this question after your response, if I may.
0
McKnifeCommented:
Open cmd.exe and use the command
Net user yourusername
It will return the group membership. If it is not in theh group "administrators", then you have found out.
0
chimaAuthor Commented:
McKnife, I deeply and sincerely apology.  Being that I was not listed (below), I would like to keep this question open.
I will contact the Sys Admins to ask why my name is not listed.
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\wmartinez>Net User l_wmartin
The user name could not be found.

More help is available by typing NET HELPMSG 2221.


C:\Users\wmartinez>
0
McKnifeCommented:
Sorry, I made a mistake.
The user is not found, because it is a domain account. net user would list local accounts.
You can however use
net localgroup administrators

Open in new window

to list all local admins and see whether your domain account is in.
0
chimaAuthor Commented:
Mcknife, that worked, yet now I see "members" which I believe I would be part of the "Domain Admins."  Others are; Helpers, LocalAdmins, and OUAdmins.  I tried variations on the "net localgroup" but none worked.  How do I see who is in the "Domain Admins?"
0
chimaAuthor Commented:
By the way; the sys admin I like to work with is on vacation until 7/10.
0
McKnifeCommented:
Check all nested groups this way:
net group helper /domain
net group "domain admins" /domain
net group Localadmins

Open in new window

and so on.
next, check
net user l_wmartin /domain

Open in new window

and see what groups you're in.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
chimaAuthor Commented:
All of the /domain commands I got "access denied."  The other "net group Localadmins gave me a help message.
So, I am blocked.  I'll have to wait until the Sys Admin gets back.
I'll close this ticket now and open another if I have to.
0
chimaAuthor Commented:
I have no objections.  chima is me and I did not select myself?
0
chimaAuthor Commented:
thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
IT Administration

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.