Network and Sharing Center shows no network connection, but computer is connected

My Windows 7 Enterprise system shows no network connection, but the system is connected.  Also, Windows Firewall is defaulting to Public.  I'm getting "want to run script" messages in Internet Explorer 11. The system was fine last time I used it, and some Windows Updates went through in the meantime, so I figure the updates may be to blame.  Unfortunately, I cannot restore back to before the updates were applied.

Any suggestions will be much appreciated.
cmmcginnAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Randy DownsOWNERCommented:
Have you tried removing and adding back to domain?
0
cmmcginnAuthor Commented:
No. I've read a lot about this issue, but none of the solutions works for me. I'm about to reinstall Windows, which resolved the issue for someone online.  I've tried using an alternate user account, but the problem persists.  It seems to have occurred following a Windows Update, but I didn't have restore points dating far enough back.

Thanks for trying to help.
0
Lionel MMSmall Business IT ConsultantCommented:
Do you have network discovery enabled and saved? If you can't save it then it is a malware issue--this is happening to a lot of people recently where network settings get messed up and the culprit is malware.
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

cmmcginnAuthor Commented:
Yes, it is enabled, but my system is defaulting to Public settings where it is disabled. I ran updated Malwarebytes yesterday and it only found for minor items that it quarantined. Doesn't seem to be malware.
0
Davis McCarnOwnerCommented:
With Vista, 7, and 8, you want to use the Repair My Computer option in the boot menu to perform a System Restore.  The reason is that you will be then running a mini-windows which prevents malware or screw-ups from recreating themselves during the obligatory reboot.
Shut the PC down.  Turn it back on and, when the manufacturer's logo appears (Dell, HP, etc.), start hitting the F8 key like a madman.  Repair My Computer -> Language -> login with your username -> System Restore
0
Lionel MMSmall Business IT ConsultantCommented:
go to registry editor and check the settings here
gpedit.msc

Computer Configuration | Windows Settings | Security Setting | Network List Manager Policies

This is a technet forum where it is discussed too
0
cmmcginnAuthor Commented:
I located the solution at this link, implemented the changes and the problem has been resolved.  Why this became necessary on my system, I doubt I'll ever know.

https://social.technet.microsoft.com/Forums/windows/en-US/df17c593-e78f-4878-97b0-7569307934c5/windows-7-states-im-not-connected-to-any-networks-when-in-fact-i-am-connected-to-my-wireless?forum=w7itpronetworking

Here's the solution excerpted from the other site:

==================

I found a solution for (my version of) this problem.  My tray icon never showed the red X, but if I clicked on the icon, the popup showed a bigger icon with a red X, and said "Not connected".  As in your case, Internet worked, but I'm unable to setup a VPN connection because it insists on using a non-existent modem, obviously because I'm "not connected" (which I am).

I monitored the processes running the NlaSvc and Netprofm services (using ProcMon), and noticed that both were denied read/write access to subkeys within the HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList hierarchy.  

The processes were running as NetworkService and LocalService, respectively, so I tried adding full access for these service accounts to the entire subkey mentioned above.  Notice that permissions are not automatically inherited in the registry, so you may need to explicitly "replace all child object permissions with inheritable permissions from this object".

Within seconds, Network and Sharing Center tells me I'm connected to my domain.  Yay!

A reboot was required to fix the tray icon and its popup.

================

Thank you everyone for trying to help.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cmmcginnAuthor Commented:
The solution corrected my computer's issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.