How to expand a .dd file from a USB source to a USB target in Linux

I have a .dd image of a Wintel Fat 16 NT4 system I need to restore to external media such that I can pull individual files from both partitions of the hard drive that was imaged. The result need not be bootable. It needs to able to be browsed and files copied inside of a Windows kernel when completed.

After wrestling with the issue inside of Windows, it appears it is best to do this from a Linux environment.
I very little functional Linux command line experience, so I am looking for a direct, step by step procedure to complete the following:

From the /root
Source file drive_image.dd on USB stick A
Restore it to USB stick B
Using the dd command.

Please assume butt stupid Linux knowledge because that is the case. Thank you.
afrendAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Duncan RoeSoftware DeveloperCommented:
Please confirm what is the Linux distribution you are using. If it's a live CD, please give URL of iso so I can run it here
afrendAuthor Commented:
Duncan RoeSoftware DeveloperCommented:
I booted it. Seems pretty standard - I used the option not to ask for the keyboard type.
You get a shell prompt as root (superuser).
First job is to mount your USB key - do you need instructions?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
afrendAuthor Commented:
I finally heard from the vendor, and it appears he is having issues at well. As I expected, an NT4 formatted FAT 16 with a DOS partition is the problem.
But thanks for looking at it this far. I have an old 9x utility that should handle this, Snapshot Drive. I just need to find a way to get an output device connected to the actual machine to use it, and being NT4, no device manager.

"It looks like the NTFS partition is either messed up or arcane enough
that Linux refuses to mount it. It might be a job for chkdsk under
Windows, but in any case it looks like it might require a bit of
creativity to extract the files, more than any predictable sequence of
commands.  I also tried copying the full image out to a 1GB USB stick
and plugging that into a Win7 box in order to use CHKDSK, but no joy.  
The NTFS partition is simply seen as empty by Windows 7.  Maybe it is a
really old version of NTFS unrecognized by modern Windows? Conceivably,
and I mean VERY conceivably, perhaps it is actually HPFS which could be
mountable under Linux with the proper modules installed; however I
haven't tried that.  HPFS uses the same partition ID as NTFS."
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.