Combobox Not selecting dropdown Values - ACCESS Forms

I have a combobox on an Access form based on a query that lists 2 set of values in the drop down but when i try to select a value from the dropdown, it selects always the first value in the combobox. I have checked to make sure that the form is not locked or the combobox is not locked. Still haven't figured out what is wrong...Help pls
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dale FyeOwner, Developing Solutions LLCCommented:
do you have the forms "Allow Edits" set to No?
peterslove53Author Commented:
form's  Allow Edits" set to  YES
field not locked
still not working
peterslove53Author Commented:
the form looks like it is actually locked, but it is not, could be inheriting some properties at runtime?
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

Dale FyeOwner, Developing Solutions LLCCommented:
Well, not likely that it is "inheriting properties", but there could be code behind the form which is changing some of those attributes.
Jeffrey CoachmanMIS LiasonCommented:
Make sure you have the correct bound column set.
For example:
You have a combobox that selects a child company of a parent company
The parent company is in Column 1 (and is the same for every Child company.)
The Child company is in column 2.

For example; Unilever is Parent company 1 with 10 child companies
1.Lipton, 2.Vaseline, 3.Knorr, 4.Axe, ..etc)
Thus setting the bound column to column1 would result in you always selecting Unilever.
So in this case you should set the bound column to 2.

So perhaps you could tell us a bit about how your system is set up....

Is the form bound to a table or a query?  Is the table or query updateable?
peterslove53Author Commented:
A bit about the combobox. The combobox filters the query of another combobox like this;
Row Source;    select * from Query1 where ID= Forms![AssignForm]!Combo34      
Row Source Type; Table/Query
locked: No

The dropdown result is exactly as wanted but does not select as if locked. The form is updatable and not locked
Jeffrey CoachmanMIS LiasonCommented:
That still does not tell us anything about the Bound column...
...Or the number of columns
Again if you are filtering ON the ID, ..and the ID is the Bound column, will always be selecting that same value...

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
peterslove53Author Commented:
select * from Query1 where ID= Forms![AssignForm]!Combo34      

the Query1 has 3 columns, ID,A,B and the dropdown, ID is the bound column (i.e 1) and it is hidden, so the width ll be
0cm:1:1 to hide the ID column. So my dropdown has just the last 2 columns
peterslove53Author Commented:
i see, i should have put the bound column something different from ID since i am filtering on ID, that solves it, thanks Jeffrey
Jeffrey CoachmanMIS LiasonCommented:
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Access

From novice to tech pro — start learning today.