RDP to Server 2012 System Fails, Unless we "wake" the server using VCenter

I have multiple Server 2008 R2 in our VMWare 5.0 environment. I have been using RDP to manage them for years without any issues.

I have recently added our first two virtual Server 2012 systems to our server farm.

I can RDP to these servers without issue, unless they have been "idle" for a while. Then I get the
"Remote Desktop can't connect to the remote computer for one of these reasons:" error.
RDP-Error.png
If I open a console session with VCenter and just get a screen up (I don't need to log in), I can then use RDP to connect to these systems.

I have changed the power settings for the NIC to not allow the system to shut it down. However, my experience with Windows 8 settings is this a USER setting, not a SYSTEM setting, so perhaps it is not in effect if no one is logged in?

Any help would be appreciated. Thanks!
JCincyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
We've seen this and it's a Power Management setting, which sleeps the OS (and the VM).

Disable Power Management Sleeping in the VM, one of our Admins, set it as a Group Policy.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JCincyAuthor Commented:
So under Control Panel / Power Options:
   
    Put the computer to sleep: NEVER

I have made this change. I need to wait to confirm this resolves the issue.

Thanks.
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Yes, turn off all functions, and set to NEVER.

Not required on a server, on in a VM.
JCincyAuthor Commented:
Thanks!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.