vsphere 5.1 storage problem using starwind

Hi all.
I appreciate this is a long intro but hopefully the actual problem is very small. Just need to give you the background.
I have what i think is a configuration issue in my lab that im hoping will be  easy answer for an expert.
Setup:
All virtual machines running on my laptop. Installed VM workstation 11.
I have 2 ESXi 5.1 VMs on ip addresses 10.0.0.215 and 10.0.0.216
2012 Domain controller IP address 10.0.0.209
vSphere 5.1 server all configured with ESXi servers and its using 10.0.0.244
So far so good. All the above works great. They allused to have addresses in the 192.168.0.x range so that they could speak to the laptop with a 192 IP address.
I changed the virtual IP range to the 10.x range because my VMs kept looking at the virgin router for DHCP addresses. I have also deployed citrix labs with dhcp options 66/67 so i need my virtual clients to go to my virtual DHCP to get not only the IP address but the bootstrap file location (that's on a xendesktop controller).
So i just changed all virtuals to the 10.x range but here is the problem i have:
The two ESXi systems are configured via vsphere to use starwind storage which is on my laptop with a 192. address. So now the ESXi servers\ vsphere can't see the data stores. I have added a 2nd NIC to the vsphere box with a 192 address and now vsphere can ping my 192. laptop ip address but here is the question... How do i get the 2 ESXi servers to see the laptop? Do i need to add virtual NICs to them with a 192 address? Do i create a 2nd virtual network? You can see i just not sure so any pointers would be appreciated.
Many thanks
Jason
LVL 1
Jay ThomasAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
What configuration is defined in VMware Workstation BAT or Bridged ?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jay ThomasAuthor Commented:
Hi, they are all on one vnet. All was working ok till I changed up range
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
and this NAT or Bridged ?
SolarWinds® Network Configuration Manager (NCM)

SolarWinds® Network Configuration Manager brings structure and peace of mind to configuration management. Bulk config deployment, automatic backups, change detection, vulnerability assessments, and config change templates reduce the time needed for repetitive tasks.

Jay ThomasAuthor Commented:
So all VMs have custom specific network including the 2 ESXi boxes.
I have added a 2nd NIC to vsphere with a 192 address, it now sees the laptop via ping.
I have also added another NIC to bo the ESXi boxes. All of these 2nd NICs are "bridged". Thing is, when i go into the network management on the ESXi boxes and look at network adapters I can only see one, I can't see the 2nd NIC to add a 192 address to - if that will even work?
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
I need to draw this network arrangement out...let me have a closer look...
Jay ThomasAuthor Commented:
Ahh a reboot perhaps Doh!
Jay ThomasAuthor Commented:
So the background.
I have several Citrix labs with various clients including PVS, Xendesktop that via DHCP need to know where the TFTP server is.
I had all virtuals on the Virgin 192 range. So for me to boot a thin client i litterally had to kil DHCP on the virgin router so that was a pain. I instead decided to switch the IP range and then of course the datastore with is on a SSD on my laptop via Starwind can no longer be accessed by anything!
My thought process is this. Add a 2nd NIC to vsphere and ESXi hosts, with a 192 address - this would work? vSphere now pings but ESXi's still couldn't see storage. I am litterally booting ESXi hosts now... Back in a minute with a report.
Jay ThomasAuthor Commented:
HI Andrew - quick update, still not had chance to get back to my lab to see if reboot fixed issue. Gte back to you as soon as I've done that.
Jay ThomasAuthor Commented:
No luck.
Can I run something past you Andrew.
Should the ESXi hosts be able to see the laptop SSD drive (starwind) the way that i have them setup? I mean, with 2 nics, one on the custom specific network and the other bridged with host. They still can't see the storage...
Jay ThomasAuthor Commented:
I gave up Andrew and put the IP range back to that of the Virgin router. I found that but powering down the virgin router once and then booting my clients they got their IP addresses with max lease time which meant subsequent reboots after the virgin router was turned back on the clients continued to use my virtual dhcp server. That was the reason for the initial change, i couldn't get my clients to use the virtual dhcp server instead of the virgin one so hence why i changed IP range.

I know you didn't offer a fix dude but you always respond and so happy to ship the points your way.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.