OS/2 - how to set a Windows logon server

I have an old proprietary application running on OS/2 until October. These PCs login to our Windows domain for file sharing purposes only. We just upgraded a couple of Windows DCs to 2012R2. We are now having issues.  Some OS/2 PCs have no issue logging in and others do. Its random which confirmed for us that those that login to 2003 servers work ok still.  

On the OS/2 PC can I make a change to LAN Manager or some INI file that will allow me to login to a specific Windows server?

Thanks
mattmcgAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

WcombeeCommented:
Can you try what is recommended Here and see if that will give you the instructions for setting up the hosts that you are looking for?
0
mattmcgAuthor Commented:
I'm sorry but I don't see where I would set the logon server name in these instructions.  I thought I may try and add the line SET LOGONSERVER = \\servername into the config.sys of the OS/2 box.
0
WcombeeCommented:
In those instructions, you could set the logon server under the hostnames, but what you said would also probably work.  It has been a long time since I worked with OS/2, but if memory serves me correctly, the hostname area on the TCP/IP configuration page would allow you to set the logon server.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

mattmcgAuthor Commented:
My SET command in the config.sys did not work.  I could not find a setting for logon server under Hostnames.  I found that OS/2 caches your password.  This was part of the issue I ran into with users being unable to authenticate to our new 2012R2 DC.  The other part was our reset tool. We have a web based utility for resetting passwords. If the user let the password expire, reset it with this tool and then login via a OS/2 PC it would not authenticate.  My resolution was on my own - a workaround was to allow the help desk here to change the users password directly through AD.  

Thanks for trying.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mattmcgAuthor Commented:
.
0
mattmcgAuthor Commented:
Was able to workaround the issue.
0
mattmcgAuthor Commented:
Issue not resolved but was able to work around it.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Operating Systems

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.