NFS issue

when a user trying to login, they are not able to see the NFS home directory. what could be the issue here.

I noticed /export/home NFS file system is mounted.

root@nisclient:~# su - myuser
No directory, logging in with HOME=/
groups: cannot find name for group ID 254
linuxpersonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

andreasSystem AdminCommented:
is user mapping working correctly? How users on this network are managed? locally on each machine or via a directory service like ldap or nis?
0
linuxpersonAuthor Commented:
when i tried on a different nis client, user able to see the home directory. is there any configuration i am missing?

root@nisclient2:~# su - myuser
groups: cannot find name for group ID 254
/export1/home/myuser> pwd
/export1/home/myuser
0
linuxpersonAuthor Commented:
users are connected with NIS

i have NIS master/slave
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Manfred BertlManagerCommented:
Is your ypserv and ypbind process running on your server? With what parameters are your nfs filesystems mounted? Pls show your /etc/exports setting and your /etc/fstab on your client. thx.
0
linuxpersonAuthor Commented:
ypserv and ybbind running the server.

when i tried to login to the client directly. I am getting the following error. i do see the directory has rw permission.
where is the permission ?

-bash: /export1/home/myuser/.bash_profile: Permission denied

cat /etc/fstab
nfsserver:/vol/home      /export1/home   nfs   rw,rsize=32768,wsize=32768,mountvers=3,nfsvers=3,noatime

root@nisclient:~# ls -ld /export1/home/myuser/
drwxr-xr-x 3 myuser14 4096 Nov 14  2014 /export1/home/myuser/
0
linuxpersonAuthor Commented:
I found the issue. the permission at the NAS level was read only

Thanks for everyone who is participating .
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
linuxpersonAuthor Commented:
NAS permission issue
I found myself.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.