Classic ASP

Hi

We are having problems getting classic ASP to work on Server 2012 with Plesk 12.

We have the classic ASP role installed and have tried removing and reinstalling. Classic asp is turned on on the settings for the domain in Plesk and there is a handler for .asp within IIS pointing to %windir%\system32\inetsrv\asp.dll.

When we call a page through the browser away from the server we get a 404 error and Remote Desktop onto the server when we double click a file IE tries to download it.

Does anyone have any suggestions please?
hobbit82Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
404 is page not found.. any code you want to share?
hobbit82Author Commented:
It is indeed, but none of the asp pages are working. Even a page with some test code?

We can pull up static http pages and images etc?
Scott Fell, EE MVEDeveloper & EE ModeratorCommented:
In Plesk, when you are in the main screen, then Server Management -> tools and settings ->  Plesk Components, can you see that ASP is active?  

If that is set up, the next thing is to make sure asp is turned on at the domain level.  Now go to your domain control panel in plesk, click on Hosting Settings.  There should be a list of options to turn on or off via a checkbox.  Make sure asp is checked.

------

Web scripting and statistics

Specify which of the following programming and scripting languages should be interpreted, executed or otherwise processed by the web server.
 SSI support (use SSI for *.htm, *.html files )
 PHP support (Run PHP as , PHP version  )
Note that switching the PHP handler type may break functionality of existing PHP scripts on this website.
Learn how to choose the most suitable PHP settings
 CGI support
 Perl support
 Python support
 Microsoft ASP support
 Microsoft ASP.NET support (Version )
 Web statistics (accessible via password-protected directory '/plesk-stat/webstat/' )
 Custom error documents
 Additional write/modify permissions
 Web Deploy publishing
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

hobbit82Author Commented:
Hi Scott

ASP is active within Plesk and active at domain level.

We have also removed the role from the server and refreshed the components before re-adding and refreshing the components again.

Its odd we are getting a 404 error via the browser externally and then internally on the server it is trying to save the ASP file? Surely the file should open via RDP on IE on the server itself?
Scott Fell, EE MVEDeveloper & EE ModeratorCommented:
Ok, I read your question again.  

"when we double click a file IE tries to download it."
I assume this means you went to the file explorer, found the file and clicked on it.  This is not the same as going to http://mydomain.com/somefile.asp from your desktop, then rdp to the server and in IE (or firefox) again go to http://mydomain.com/somefile.asp.

Had the .asp file been a plain html file with the extension .html, then clicking on it would show the page as if you were surfing.  But this would not be the case for .asp (or .aspx or .php).

It sounds like your real issue not finding the file.  In plesk, your .asp file is probably in vhosts\yourdomain.com\httpdocs\somefile.asp where httpdocs folder is the top level for your domain.  Verify the set up and that your asp file is top level of where the domain is.  Verify that asp is turned on in plesk for the domain you want to access.  Verify via rdp (or ftp) that the file exists in the domain.  You may want to start with a simple .txt file just to rule out anything with asp.  I do think you have to solve  your domain issue though.
David Johnson, CD, MVPOwnerCommented:
rdp uses port 3389 and doesn't use http protocol on port 80
in IIS is asp enabled? and do you have the correct default document set?
Scott Fell, EE MVEDeveloper & EE ModeratorCommented:
I think what he means to do is rdp to the server, then fire up the browser on the server and go to http://somedomain.com/thepage.asp.  This is common to view detailed errors if you are not sending detailed errors to the browser outside of the server.  

My guess is he is useing the file manager and clicking on the actual asp file.  I think it is just confusion on how to view the asp page.
hobbit82Author Commented:
In the end we turned off friendly error messages on the browser and when visiting the website it showed an ODBC error.

We moved the MDB database over from the old server and set this up in Plesk, following this checked the permissions on the DB directory to allow the IIS user to access and this resolved the issue.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hobbit82Author Commented:
Found own solution.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP

From novice to tech pro — start learning today.