Global address list not updating

I am the administrator of a Small Business Server 2008 domain with 50 computers running as clients on a remote desktop service server.
All clients run Office 2010 with Outlook 2010.

My problem is that the GAL within Outlook is not automatically updated.
Then I asked my users to do a manuel update from Outlook from FILES -> ACCOUNT SETTINGS -> UPDATE GLOBAL ADDRESS LIST.
Apparently this caused Outlook to delite the list of cached email adresses??

Therefore this is really 2 questions:

1) Why does the GAL not updating?
2) Why does a manuel update delete cached passwords?
OhmitAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
You are not talking about the GAL. You are talking about the OAB. While they can seem the same, they are not.

If you login to OWA you will see the GAL - that uses live information. Therefore the first thing you need to do is check whether changes to user accounts are seen through OWA. If they are, then the problem is with the OAB distribution.

Is the server fully up to date?
Any errors in the event viewer about OAB generation? Run the SBS BPA and Exchange BPA (in the toolbox in EMC) to ensure that no errors come up.

Choosing the option to Download the Address book should have had no effect on the nickname files. I have never seen the entries lost by doing what you posted. Therefore that must have been caused by something else.

Simon.
0
Marwan OsmanCommented:
uncheck the use cache exchange mode in the account settings and try.
0
Tony GiangrecoCommented:
I have the same problem in Exchange 2007. When I added or deleted mailboxes, the updates were found in All Users.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Simon Butler (Sembee)ConsultantCommented:
"uncheck the use cache exchange mode in the account settings and try. "

That isn't really a fix.
That just stops the client from using the OAB. The live GAL rarely has a problem.

All Users is the live information, therefore if you aren't seeing the information elsewhere, then the OAB isn't updating correctly. You shouldn't need to go near All Users at all.

Simon.
0
Marwan OsmanCommented:
Simon Butler (Sembee)

you are right 100%, thank you.
0
Md. MojahidCommented:
Try this

1. Open the Exchange Management Console.
2. Go to Organization Configuration, and then click Mailbox.
3. Right click the appropriate database and go to Properties
4. Click on the Client Settings tab, do you have an OAB set?
5. If no click Browse and select the correct OAB and Ok and Ok
0
Will SzymkowskiSenior Solution ArchitectCommented:
You may want to check your EWS (Exchange Web Services) to ensure that is it properly configured as you are using Web Distribution for Outlook 2010. You may also want to change the Distribution Server to another CAS server in your environment if you have one, which would be a good test to see if there is something wrong with the current one being used.

Will.
0
OhmitAuthor Commented:
Honored colleagues.

This is getting more and more strange.

First of all I dont see any entries in the ewent viewer what so ever regarding any issues related to OAB or a like.

I just ran BPA which only commant was, that incomming/outgoing message size is too high.

If I access OWA and press the to-buttom it shows me a VERY outdated address book only showing 1/3 of the current users.

If I access Outlook 2010 I see the full internal address list (GAL??) except that this is not updated and missing newly created users.

"Huston we have a problem" :-)
0
Simon Butler (Sembee)ConsultantCommented:
That suggests the server has a problem with the domain.
It is either unable to query the domain properly or there is a replication issue.

Probably the first time for many months where the problem has been genuinely the GAL, rather than the OAB.

You need to start looking at your domain controllers. Specifically look at the ones that Exchange is using for global catalog. If you have multiple DCs with the global catalog role, try removing the GC role from the server that Exchange is using, then restart the Exchange services so that Exchange is forced to use it.

Exchange doesn't cache the GAL information, so you aren't looking at out of date information from within Exchange, it is incomplete information from the domain.

Do check the obvious though - that the mailboxes don't have hide from the address book enabled. I would also ensure that permission inheritance is enabled on every user account.

Until you can see all of the information in OWA, don't think anything is going to change on the clients.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.