Outlook certificate problems

Hi Experts,

since tonight I have problems in outlook 2010 with a certificate.
can you help me to repair this cert issue ?
The server in the backend is an EXCH2007 cluster.

The error message is in german and not in english, sorry for that.
I try to translate is....

Error: the name of the certificate is not valid or the name is different from the website.

Can you help me out to solve this issue ?
Eprs_AdminSystem ArchitectAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MAS (MVE)EE Solution GuideCommented:
0
Eprs_AdminSystem ArchitectAuthor Commented:
I tried to change the service with this cmd

Enable-ExchangeCertificate -Services IMAP, IIS, SMTP -thumbprint

But the services are not changed.
The command seems to be ok, no error message.
But when I check again get-exchangecertificate |fl nothing changed.

On my service I have enabled SMTP and IIS but how to delete one entry ?
0
Eprs_AdminSystem ArchitectAuthor Commented:
I checked your article.
Each output is ok.

I want to change some services on the certificate.
The command is ok but no service changed.
Do you know why ?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Eprs_AdminSystem ArchitectAuthor Commented:
here is a screenshot....cert-error-mail.hbg.JPG
0
MAS (MVE)EE Solution GuideCommented:
The above screenshot is a clear case of certificate name/URL mismatch. If you follow my article your error will get cleared
If yes please check below
Type "Get-ExchangeCertificate" and check the thumbprint
Type this command to enable services on the correct certificate

Enable-ExchangeCertificate -Thumbprint 49D53353A1FBDE31C34604A8EF52FC9BABA187C8 -Services IIS,SMTP,IMAP

Open in new window

0
Eprs_AdminSystem ArchitectAuthor Commented:
Yes I followed your article.
0
Eprs_AdminSystem ArchitectAuthor Commented:
OWA is working
0
Eprs_AdminSystem ArchitectAuthor Commented:
on my certificate are 2 services enabled

Services           : IMAP, POP, SMTP

But still getting the pop up when opening Outlook.
0
MAS (MVE)EE Solution GuideCommented:
You should enable IIS on the 3rd party certificate using the above command which explained in my article
0
Eprs_AdminSystem ArchitectAuthor Commented:
OK, I have enabled IIS on the certificate.
Nothing changed.

Strange is , when I enable IIS on one cert, on the other it is removed.
Can you explain this behavoir ?
0
Eprs_AdminSystem ArchitectAuthor Commented:
When I add IIS on the first cert, then on the second cert IIS is removed and owa stopped working, why ?
0
Eprs_AdminSystem ArchitectAuthor Commented:
I have two HUB servers, do I have to do this on both ?
0
Eprs_AdminSystem ArchitectAuthor Commented:
please help me out with this cert djungle...maybe we can check this from the beginning, step by step.
0
MAS (MVE)EE Solution GuideCommented:
-->I have two HUB servers, do I have to do this on both ?
yes you have to do this on both
0
Eprs_AdminSystem ArchitectAuthor Commented:
Ok,

I have two certs:

mail.domain.local -> this email has the bindings SMTP,POP
mobile.domain.at -> this email has the bindings SMTP,IMAP,IIS

With this setting I have the error which you can see in the picture.
When I add IIS to mail.domain.local then OWA stopped working, because IIS is moved to the other cert mobile.domain.at

Is it possible to delete one of the SMTP bindings on these certs ?
I tried the command enable-exchangecertificate....... but nothing changed.
0
Eprs_AdminSystem ArchitectAuthor Commented:
And I found out, in my certificates, no autodiscover SAN is inside.
Do I need this link inside my certs ?
If yes how to change this or add more SANs ?
0
MAS (MVE)EE Solution GuideCommented:
Yes you need autodiscover.domain.com in certificate as explained in my article.
Otherwise you will get this error.

You have to contact your 3rd party CA and ask them how to add.
They will explain to you.

-->Is it possible to delete one of the SMTP bindings on these certs ?
No you keep SMTP on both self signed and 3rd party certificate as it is recommended to have SMTP on self signed because it will be used for inter server communication.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Eprs_AdminSystem ArchitectAuthor Commented:
Great Job man.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.