CTRL key getting stuck in 2012 RDS session

We have a 2012 R2 RDS environment. Clients RDP in from Windows 7 clients, fully patched, including RDP client 8.1, utilizing RDWeb to connect to remote session.
We have been having issues with users having the CTRL key stuck in the remote session. There is a group policy that locks a users local computer after 15 minutes of inactivity. So, users walk away and when they return their computer is locked. They hit CTRL-ALT-DEL to unlock their computer, then they log in. Now, they open their RDP session, and the CRTL key acts as if it is stuck. For example, if they are in Outlook, every email they click gets highlighted, or if they are in IE, and type 'N'' a new page opens.
We have found the way to fix this is to tap the CTRL key a couple times, and it fixes the issue. This is not a solution though, just a workaround. I have found many articles about this being a problem on 2008 RDS, in which hot fixes were released. However, I have not been able to find anyone with this issue on Server 2012 RDS yet.
Any ideas?
LVL 1
CCtechAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brett DanneyIT ArchitectCommented:
This is a strange issue. The only two things I can think to try are to turn off sticky keys:
http://www.techrepublic.com/blog/windows-and-office/quick-tip-disable-the-sticky-and-filter-keys-in-windows/

Or alternatively disable the server requiring to have ctrl, alt, del pushed to login. This can be done from a group policy, users will still need to login just the screen saying push ctrl, alt, del to login disappears and is replaced with a normal login screen.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CCtechAuthor Commented:
Thanks, Sagi,

    Sticky keys are disabled. As a temporary work around I have disabled the interactive logon requiring ctrl-alt-del. Thanks for the suggestion.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.