OpenCart Stores

Hi, I went through the steps here: http://code.tutsplus.com/tutorials/create-a-multi-store-setup-using-opencart--cms-22261

So, for store one, Chino, I have these set up, please see screenshots.
Opencart relevant setup
subdomainBut, when I go to chino.m2ucheckout.com, I see this:
chino. etc

Have I missed something? Thanks! Please let me know if you need any more information.
mel200Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ess KayEntrapenuerCommented:
Looks lke you are missing a store installation, or a redirect
0
Ess KayEntrapenuerCommented:
Ah... yes --> here is the line

So I assume that "store1.myexamplestore.com" is also pointing to the same document root as that of the "http://www.myexamplestore.com".


you need to edit your hosting to point Document Root of second store to the first store
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mel200Author Commented:
ahhhh.. ok. um.. my domain is at godaddy, hosting is at Arvixe. So I do that at Arvixe.  I would guess that is something that needs to be done on the server, by the hosting techs? Thanks.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

mel200Author Commented:
thanks!
0
mel200Author Commented:
Hi, I have to come back to this, I deleted the old opencart installation, and installed http://m2ucheckout.com. So now they're on the same document root, is that right?  

I recreated the store chino.m2ucheckout.com. I checked that I still have the subdomain on the cpanel. But I still get the same thing:  http://chino.m2ucheckout.com

Any other thoughts on this?  Thanks.
0
Ess KayEntrapenuerCommented:
in your first picture,  see the subdomainds have a 'document root'

that means what folder it points to


the publichtml/chino is actually
c:/webserverstuff/publichtml/chino

you want to edit that to
look like this
publichtml/m2ucheckout.com  (or whatever folder your main site is in on the computer/server


so it will point to the same folder regardless what address you type in,
 http://chino.m2ch...  or www.m2ch...
0
Ess KayEntrapenuerCommented:
you would need to go into your hosting account for this,  not godaddy,  because the hosting is where those folders are
0
mel200Author Commented:
Hi, again. Under the new store on opencart, there is a tab called Store, and in there you can set default layout. I set it to category. Then I added a category, and assigned it to that store, added product and assigned it to that store. I still have nothing. I'm going to continue to research, but I'm hoping you can help out. :)
0
mel200Author Commented:
Oh, I see what you mean. Ok, let me fix that. Thanks.
0
mel200Author Commented:
ok, now I have it as: chino
That is right, I hope? :) thanks again.
0
mel200Author Commented:
Nope, I re-read what you put, and it's not right. One more time.
0
mel200Author Commented:
ok.. now I have this, and I think it is what you suggested:
chino new
0
mel200Author Commented:
But it redirects to http://stats.starfish.arvixe.com/. I'll try deleting and rebuilding the store on opencart.
0
Ess KayEntrapenuerCommented:
open your regular domain settings.  look at the document root there and copy it


then

go to the subdomain page,  and paste
0
Ess KayEntrapenuerCommented:
no need to rebuild,  just need to set up the pointer correctly
0
mel200Author Commented:
ok, will try that, sorry I'm so dim about this.
0
mel200Author Commented:
OK, there is no link for domains, only subdomains and parked domains. But there is this:

stats-home-domain
0
mel200Author Commented:
Aha! It was caching! in a new browser it is working now. Thanks for your help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.