Emails are being sent to the junk folder

Here is my situation. I have a user on an iMac using Outlook 2011. They have an SBS 2008 server with Exchange 2007. They have Mcafee SAAS spam filtering. They have a windows domain, but the iMac is not joined to it.

The user has one domain that always goes to their junk folder. The domain is wufoo.com. I have added exceptions in the external spam filter and outlook for the domain and the addresses it is saying are junk. I have also disabled junk email protection in outlook. The emails are still going to junk. Normally this wouldn't be a big deal, but this user is the HR person and the emails being blocked are incoming resumes. No one else in the company has problems with emails going to junk like this that I know of.

Does anyone have any ideas why this might be happening?
LVL 2
Blake LongEngineerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
I am familiar with Outlook in general but not Outlook 2011. Check in Junk Options (main Outlook Ribbon) that:

1.  Junk Options, Options tab has the No Automatic Filtering radio button checked ON and no other options set on that screen.

2. That wufoo.com is not blocked in the International Tab.

3. That wufoo.com does not show up anywhere in Blocked Senders.

4. You may wish to allow wufoo.com in Safe Senders.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Blake LongEngineerAuthor Commented:
We had done everything mentioned except we hadn't added the domain in the safe senders list. Once we did that emails started coming through to the inbox.
JohnBusiness Consultant (Owner)Commented:
@Blake Long  - Thanks for the update and I was happy to help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.