Sharepoint 2010 FULLCRAWL ERRORS 10016 and 14

SharePoint 2010 SP2 FARM

I was trying to run a full crawl because my search is fully not working and I believe   it is because of this error

I ran this command line

PS C:\> stsadm -o spsearch -action fullcrawlstart

Operation completed successfully.

But I got these two errors the Event Id 10016 happened 75 times event 14 only once for this time period


Log Name:      System
Source:        Microsoft-Windows-DistributedCOM
Date:          6/22/2015 10:13:52 AM
Event ID:      10016
Task Category: None
Level:         Error
Keywords:      Classic
User:          mydom\spserv
Computer:      SERV013.FQDN.com
Description:
The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
{B15C0E47-C391-45B9-95C8-EB596C853F3A}
 and APPID
{FA3FC5CF-0304-4CAC-99F0-032AC2B15D1E}
 to the user mydom\spserv SID (S-1-5-21-3054588571-1341459584-784128302-3140) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
    <EventID Qualifiers="0">10016</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8080000000000000</Keywords>
    <TimeCreated SystemTime="2015-06-22T14:13:52.897191300Z" />
    <EventRecordID>24616</EventRecordID>
    <Correlation />
    <Execution ProcessID="620" ThreadID="5332" />
    <Channel>System</Channel>
    <Computer>SERV013.FQDN.com</Computer>
    <Security UserID="S-1-5-21-3054588571-1341459584-784128302-3140" />
  </System>
  <EventData>
    <Data Name="param1">machine-default</Data>
    <Data Name="param2">Local</Data>
    <Data Name="param3">Activation</Data>
    <Data Name="param4">{B15C0E47-C391-45B9-95C8-EB596C853F3A}</Data>
    <Data Name="param5">{FA3FC5CF-0304-4CAC-99F0-032AC2B15D1E}</Data>
    <Data Name="param6">MYDOM</Data>
    <Data Name="param7">spserv</Data>
    <Data Name="param8">S-1-5-21-3054588571-1341459584-784128302-3140</Data>
    <Data Name="param9">LocalHost (Using LRPC)</Data>
    <Data Name="param10">Unavailable</Data>
    <Data Name="param11">Unavailable</Data>
  </EventData>
</Event>



Log Name:      Application
Source:        Microsoft-SharePoint Products-SharePoint Foundation Search
Date:          6/22/2015 10:13:32 AM
Event ID:      14
Task Category: Gatherer
Level:         Warning
Keywords:      
User:          MYDOM\spserv
Computer:      SERV013.FQDN.com
Description:
The start address sts4://tgcs013:29261/contentdbid={ac89cd5e-197e-46c6-b681-11fa35974595} cannot be crawled.

Context: Application 'Search_index_file_on_the_search_server', Catalog 'Search'

Details:
      Access is denied. Verify that either the Default Content Access Account has access to this repository, or add a crawl rule to crawl this repository. If the repository being crawled is a SharePoint repository, verify that the account you are using has "Full Read" permissions on the SharePoint Web Application being crawled.   (0x80041205)
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-SharePoint Products-SharePoint Foundation Search" Guid="{1C415899-58B3-4BFC-9236-105E7FD38719}" />
    <EventID>14</EventID>
    <Version>14</Version>
    <Level>3</Level>
    <Task>174</Task>
    <Opcode>0</Opcode>
    <Keywords>0x2000000000000000</Keywords>
    <TimeCreated SystemTime="2015-06-22T14:13:32.235213200Z" />
    <EventRecordID>24581</EventRecordID>
    <Correlation />
    <Execution ProcessID="5092" ThreadID="5852" />
    <Channel>Application</Channel>
    <Computer>SERV013.FQDN.com</Computer>
    <Security UserID="S-1-5-21-3054588571-1341459584-784128302-3140" />
  </System>
  <EventData>
    <Data Name="string0">sts4://serv013:29261/contentdbid={ac89cd5e-197e-46c6-b681-11fa35974595}</Data>
    <Data Name="string1">

Context: Application 'Search_index_file_on_the_search_server', Catalog 'Search'

Details:
      Access is denied. Verify that either the Default Content Access Account has access to this repository, or add a crawl rule to crawl this repository. If the repository being crawled is a SharePoint repository, verify that the account you are using has "Full Read" permissions on the SharePoint Web Application being crawled.   (0x80041205)</Data>
  </EventData>
</Event>


Thoughts
LVL 23
Thomas GrassiSystems AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

martushaProduct managerCommented:
For the first error its description decribes itself:
The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID  {B15C0E47-C391-45B9-95C8-EB596C853F3A}
  and APPID  {FA3FC5CF-0304-4CAC-99F0-032AC2B15D1E}
  to the user mydom\spserv SID (S-1-5-21-3054588571-1341459584-784128302-3140) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

Start>Administrative Tools>Componant Serivces
Expand Computers
Expand My Computer
Highlight DCOM Config
At the top, on the tool bar click the button for Details.
On the right, find the application and change it's permissions (add spserv user and grant local activation and local launch permissions)
Read more in this answer: https://social.technet.microsoft.com/Forums/sharepoint/en-us/3313c6c5-383a-4051-a22a-04452f87642a/the-machinedefault-permission-settings-do-not-grant?forum=sharepointsearch
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
martushaProduct managerCommented:
For the second error, go to central admin and check permissions of web application, there should be your search account and Default content access account both with full read permissions.
0
Thomas GrassiSystems AdministratorAuthor Commented:
Martusha

Error 10016 is fixed with the dcom changes. reran
PS C:\> stsadm -o spsearch -action fullcrawlstart

Now still getting error 14

The start address sts4://tgcs013:29261/contentdbid={ac89cd5e-197e-46c6-b681-11fa35974595} cannot be crawled.


this site is Central Administration

For the second error, go to central admin and check permissions of web application, there should be your search account and Default content access account both with full read permissions.


I can not change or look at this information for Central Administration

Why are we trying to crawl Central Administration?  Do we need to?

I have two other Web Applications and they both have user spserv with full read access

Thoughts?
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Mohit NairSenior AssociateCommented:
You need not crawl central admin. Please go to search service application and click on content sources. Remove the central admin url from the entry. Wait for next crawl to run and the error wont appear again.
0
Thomas GrassiSystems AdministratorAuthor Commented:
M ohit

Nice to hear back from you.

This is what I found

These where the only URL's Listed see attached image

http://mysite.tgcsnet.com
http://sharepointtgcs.com
http://tgcs013:8888
sps3://sharepointtgcs.com


I remember http://tgcs013:8888 is the test one you setup  correct?

I do not see central administration listed

So why is it the cause of error id 14 in the above message?


what is sps3://sharepointtgcs.com  ?????



Thanks
Sharepoint-2010-Content-Source.png
0
Mohit NairSenior AssociateCommented:
sps3://sharepointtgcs.com is the entry for the people search to work on your site. Stop and restart the search service, then the error shouldn't reappear.If it still persists, you may have to perform index reset and start the full crawl again.
0
Thomas GrassiSystems AdministratorAuthor Commented:
Mohit

Stop and restart the SharePoint Server Search 14 service?
or stop and restart SharePoint foundation Search V4 service?
Do this from the Services MMC ?  or in Central Admin?

How do I perform a index reset?


Thanks
0
Mohit NairSenior AssociateCommented:
Stop and restart the SharePoint Server Search 14 service. Do it from cmd prompt
net stop spsearch14
net start spsearch14
0
Thomas GrassiSystems AdministratorAuthor Commented:
Mohit

Ok I did this

net stop osearch14
net start osearch14  

No errors doing that


I am doing a Index Reset now.
0
Thomas GrassiSystems AdministratorAuthor Commented:
Mohit

Index reset finished

ran this
PS C:\> stsadm -o spsearch -action fullcrawlstart


same error 14


Thoughts
0
Thomas GrassiSystems AdministratorAuthor Commented:
Mohit

Update

I use this method to do a full crawl
Central Administration : Search Service Application 1: Manage Content Sources

Now My site can search new content.

Do I need to do this manually every so often or is there a timer job to do this? If so which timer job.

I did get 2 errors during full crawl one was for http://tgcs013:8888 I deleted that url since it was a test site that will clear that error the other error was this

Log Name:      Application
Source:        Microsoft-SharePoint Products-Web Content Management
Date:          6/25/2015 10:01:24 AM
Event ID:      7362
Task Category: Publishing Cache
Level:         Warning
Keywords:      
User:          OUR\sp_mysite
Computer:      TGCS013.our.network.tgcsnet.com
Description:
Object Cache: The super user account utilized by the cache is not configured. This can increase the number of cache misses, which causes the page requests to consume unneccesary system resources.
 To configure the account use the following command 'stsadm -o setproperty -propertyname portalsuperuseraccount -propertyvalue account -url webappurl'. The account should be any account that has Full Control access to the SharePoint databases but is not an application pool account.
 Additional Data:
 Current default super user account: SHAREPOINT\system
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-SharePoint Products-Web Content Management" Guid="{0119F589-72D7-4EC3-ADF5-1F082061E832}" />
    <EventID>7362</EventID>
    <Version>14</Version>
    <Level>3</Level>
    <Task>1</Task>
    <Opcode>0</Opcode>
    <Keywords>0x4000000000000000</Keywords>
    <TimeCreated SystemTime="2015-06-25T14:01:24.862542200Z" />
    <EventRecordID>25623</EventRecordID>
    <Correlation ActivityID="{C3D49A38-9560-4B26-8E7F-BF78FB6CAE2E}" />
    <Execution ProcessID="9364" ThreadID="12068" />
    <Channel>Application</Channel>
    <Computer>TGCS013.our.network.tgcsnet.com</Computer>
    <Security UserID="S-1-5-21-3054588571-1341459584-784128302-3144" />
  </System>
  <EventData>
    <Data Name="string0">SHAREPOINT\system</Data>
  </EventData>
</Event>



Thoughts
0
Thomas GrassiSystems AdministratorAuthor Commented:
Mohit

Update

I checked the crawl log and found these warnings

HTTP://mysite.tgcsnet.com
This item and all items under it will not be crawled because the owner has set the NoCrawl flag to prevent it from being searchable

http://sharepointtgcs.com/my
This item and all items under it will not be crawled because the owner has set the NoCrawl flag to prevent it from being searchable


Thoughts
0
Mohit NairSenior AssociateCommented:
Please ignore 7362 warning. You need not manually crawl the content. You can set an incremental crawl schedule for everyday after 10 PM and full crawl schedule once in a month on a weekend. It will do its work automatically.

Go to mysite Site Settings –> Site Administration –> Search and Offline Availability for the site in question and set the "Indexing Site Content" switch to "Yes"
0
Thomas GrassiSystems AdministratorAuthor Commented:
Mohit

I just figured out this

I was just looking at Central Administration for site settings I need to bring up each site then go to site settings.

So I turned of Indexing for Central Administration site. And on for the other sites. That should clear that message now.

Under Job Definitions I can not find any thing for Crawl

Where do I find those jobs?
Will there be one for each site?
What is the job definition?


Also I am still getting Event ID 7362  Should I open a new question for that?

I have another question that I opened if you can take a look also

http://www.experts-exchange.com/questions/28692479/Sharepoint-2010-Event-Id-10016-Everytime-A-document-is-Open-from-the-Shared-Documents-Site.html


Thanks
0
Thomas GrassiSystems AdministratorAuthor Commented:
Mohit

Update

I figured out how to schedule the crawl jobs  setup Full for once a month and incremental daily.
0
martushaProduct managerCommented:
If you want new documents or items will be searchable after you add them, you may need to configure incremental craw every 10-15 min. Full craw could be once a week.
0
Thomas GrassiSystems AdministratorAuthor Commented:
Guys

First Full site Crawl ran tonight no errors

Thanks

Still getting 7362 error will post new question later on that one.
0
martushaProduct managerCommented:
Cool!

7362 is about super user account?
0
Thomas GrassiSystems AdministratorAuthor Commented:
Martusha

Yes I found this

http://social.technet.microsoft.com/wiki/contents/articles/20699.sharepoint-2010-event-id-7362-the-super-user-account-utilized-by-the-cache-is-not-configured.aspx

Going to do this now

I had trouble with the stsadm command the webappurl parameter and I finally figured it out
was a syntax problem

Got the command to work and applied them today will key eye out.



Do you have time to take a look at these two also.

http://www.experts-exchange.com/questions/28692479/Sharepoint-2010-Event-Id-10016-Everytime-A-document-is-Open-from-the-Shared-Documents-Site.html

Thanks
http://www.experts-exchange.com/questions/28689801/Sharepoint-2010-Add-Spprofilleader-failed-User-has-a-Manager.html
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.