Turnkey Linux SSL installation

Hi all

We have a Linux Webserver that requires a SSL certificate installed. I have generated the files according to the Comodo SSL guides. But I can't get it to load apache with the new certs. I have tried changing the conf files and i get errors that the server can't reliably determine the server's fully qualified domain name and it doesn't start at all.

I can give more details if needed but I am not sure what to send.

Kind regards
Francois
e-itregisterAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zephyr ICTCloud ArchitectCommented:
Is your hostname configured correctly? What displays when you type "hostname" on the cli?

You can try by adding your hostname into a file and link it ... Something like this:

Create a file in /etc/apache2/conf-available/ and name it something like server_name.conf

In that file put this: ServerName <your-hostname>

Safe and close the file then run following command:  a2enconf server_name
0
e-itregisterAuthor Commented:
It is running wordpress and when I type in hostname it shows wordpress. Can I change this without breaking my wordpress?
0
Zephyr ICTCloud ArchitectCommented:
You should be able to create the file without interrupting anything ... But running the a2enconf script might interrupt it shortly ... It might not but there's a small risk so...
0
ON-DEMAND: 10 Easy Ways to Lose a Password

Learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees in this on-demand webinar. We cover the importance of multi-factor authentication and how these solutions can better protect your business!

e-itregisterAuthor Commented:
Can I revert the changes if something goes wrong? I tried to type in a2enconf but said command not found. Do i need to install it first?
0
e-itregisterAuthor Commented:
My server also doesn't have a conf-available folder. please see attached screenshot
Clipboard01.jpg
0
Zephyr ICTCloud ArchitectCommented:
Ok, first off ... I have to say that the warning you receive is just a warning, it should not have influence to get ssl to work, but that being said we need to get it gone if possible... Let's try a different approach.

Open up apache2.conf in the /etc/apache2/ directory and at the very bottom enter this:

ServerName wordpress

Open in new window


Where wordpress is your hostname as you mentioned.

Now restart Apache and with some luck the error message dissapears.

It might not solve the ssl issue though ... We will need to continue troubleshooting that.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
e-itregisterAuthor Commented:
Hi

Thanks that solved the name issue. Not the other issue yet.
0
Zephyr ICTCloud ArchitectCommented:
Ok, as I suspected ... Can you give me an overview of what you have configured for the ssl?
You have the keys, set the permissions on the files (keys) in /etc/ssl/certs/ and adjusted the config in your Apache to reflect this?

Maybe you can post a screenshot of the config?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SSL / HTTPS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.