Network cards - Unexpected error occurred

Hi,

I have a computer windows 7 32 bits, when i click on properties of any network card (wireless, lan, bluetooth), i get an error message : "An unexpected error occurred." I can't disable, diagnose or view status of any network card, but they are working though.

What I have done so far:

- Uninstall every devices
- Tried in safemode
- Register netshell.dll and ole32.dll
- chkdsk /r
- sfc /scannow (found some corrupt files and repaired them)
- scan the whole computer with Malwarebytes

Nothing worked so far, any idea what I could do next ? I'm running out of ideas...

Thanks,

Guillaume
ti-guyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nader alkahtaniConsultantCommented:
Reinstall TCP/IP stack
Use Network Troubleshooter
Use driver booster from iobit
nader alkahtaniConsultantCommented:
All that with administrator prevelegs
ti-guyAuthor Commented:
Yes, all done with the administrator account. I'll try these 3 things and come back, thanks.
SD-WAN: Making It Work for You

As bandwidth requirements and Internet costs grow, businesses naturally want to manage budgets by reducing reliance on their most expensive connection types. Learn more about how to make SD-WAN work for your business in our on-demand webinar!

nader alkahtaniConsultantCommented:
if didnot success then try to ping 127.0.0.1 if not success or replay more than 1 ms then your NIC may be damaged
ti-guyAuthor Commented:
I've updated everything with iobit, reinstall TCP/IP stack, network troubleshooter found nothing...

And I can ping 127.0.0.1.

I still get the message "An unexpected error occurred" when i click properties...
nader alkahtaniConsultantCommented:
Do you see any thing in device manager,  choose view hidden devices,  is there any (?) mark or !
 Check with eventvwr tool
ti-guyAuthor Commented:
Thanks a lot for your time.

Everything is fine in device manager, every hidden devices.

I tried to install a newer version of  Intel PROSet/Wireless Wifi Software , and it asked to uninstall the old one first.

I get an error that the path 'C:\Windows\installer......\...Wireless.msi' cannot be found. Verify that you have access to this location and try again. or try to find the installation package..

Could this be related ?
ti-guyAuthor Commented:
I found the problem !

I had to go to the Component services (dcomcnfg) and change the properties of My computer. Under the tab Default Properties, put Impersonate instead of Anonymous.

Thanks for your time !

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ti-guyAuthor Commented:
DCOM problem.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.