Max - Cannot RDP

Dear Experts,

Yesterday, I was able to login to the Hyper-V virtual PC. But after restarting the server, I am now not able to login to the PC by RDP but by sonicwall SSL-VPN I can.

What settings do I need to enable so that remote desktop login can be achieved again?
LVL 1
Anonymous KHIT EngineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Lee W, MVPTechnology and Business Process AdvisorCommented:
Check your firewall profile on the VM and the host - I've seen them revert to public and public should (by default) block RDP.  Let me know if that's the problem.
0
Anonymous KHIT EngineerAuthor Commented:
Firewall on the Hyper-V server is off.

Firewall on virtual PC is also off.
0
Blue Street TechLast KnightCommented:
Hi Kevin,

Honestly, this is a good thing...RDP shouldn't be open to the world...ever or even by limiting the sources (explicitly defining them). It's a security best practice to block RDP (3389) because it's a ubiquitously know attack vector. Obfuscating the port is not a viable security defense either, e.g. setting up port redirection <host>:34987 > 3389.

Regardless, if both machines firewalls are disabled then check your gateway/perimeter firewall (SonicWALL). Do you have 3389 open on the SonicWALL. Again, I'd recommend using the SSL-VPN and then RDP'ing into your machine. You can automate this process with a simple modification of the batch file included in the NetExtender client too. That will auto launch the RDP client after successful VPN login.

Keep me posted.

P.S. You should remove the XP machine from your network...XP is also a major security attack surface. Upgrade to Window 8.1 or 10...at very least Windows 7.
P.P.S. RDP+XP = security nightmare. Might as well throw your firewall away and parade your data around naked for anyone to take. :)
0
Anonymous KHIT EngineerAuthor Commented:
Hi Experts,

I found that the reason is because the newly installed Kaspersky software by default has blocked RDP connections, and after I enabled it and save the setting. The connection was restored.

Thank God.

Something new I learnt.

Kaspersky-Firewall-Default-Settings.JPG
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Anonymous KHIT EngineerAuthor Commented:
It is the solution that worked.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.