Exchange overwriting contact in phone with GAL info

Hi
Exchange 2010 and an Android (Samsung galaxy s5).
For a while it worked fine, but now seems that any changes I make to a contact on my phone that also exists in the global address list, within a day or two, the information from the GAL overwrites what's in my phone.

One example where this is frustrating, is each employee has an office extension, so their office number may be: 123-456-7890 x110.  Another employee would be 123-456-7890 x111, and so forth.  I have a few dozen of them in my phone, so if anyone of them call from the office line, it will show the most recent employee I called.

In the past I'd got around this by modifying the contacts in my phone and removing their office numbers (keeping only their cellphone numbers), and then keeping a single contact on my phone for the company.   So when anyone called from inside the company, the contact on my phone showed a receiving call from "Company contact".

Very frustrating.  Any idea why this is happening or what i can do to prevent it?
Mystical_IceAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mystical_IceAuthor Commented:
Noticed on the contacts where numbers are entered back in when i was certain i removed them, there's a note in the description (proving it's not my imagination!) :


Details Updated 6/30/2014:
Business Phone: (xxx) xxx-xxx ext 203

Details Updated 6/11/2015:
Business Phone: (xxx) xxx-xxx ext 203

Details Updated 6/16/2015:
Business Phone: (xxx) xxx-xxx ext 203

Details Updated 6/21/2015:
Business Phone: (xxx) xxx-xxx ext 203


Still weird that an entire year went by (06/14 to 06/15) before it started happening...
0
Mystical_IceAuthor Commented:
For anyone searching for this same problem, it turned out to be Microsoft Outlook's "Social Connector", which was automatically updating contacts based on the global address list.

By default it's turned on, so to turn it off on Microsoft outlook 2007 or 2010, navigate to the "view" tab (ribbon), then click 'people pane', then 'account settings'
On the account settings window, click 'settings', then "Never update"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.