Connecting and listing with FTP on IIS

Hi,
I have set up an ftp site on IIS on Windows Server 2012 Datacenter (Azure VM). I followed the instructions here:
http://itq.nl/walkthrough-hosting-ftp-on-iis-7-5-a-windows-azure-vm-2/
I can connect to the server locally and list the contents of the directory using FTP at the command line. I can also connect remotely using the FTP at the command line. When I try to connect using Filezilla or other FTP software I get the following error:
"Connection timed out after 20 seconds of inactivity", "Failed to retrieve directory listing".

The fact that I can connect remotely with FTP CMD means I probably have it set up correctly. I tried setting transfer modes to Default, Active and Passive in Filezilla. The account I'm connecting with has correct permissions on the directory.

What could be the problem?

Thanks.
A
ftperror.png
abigulAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KimputerCommented:
Is there any firewall involved? If so, also let the passive ports pass the firewall (of course, try to set it up in a smaller range, otherwise you'll be opening your whole server). Using Filezilla Server is much easier (and more features) though, so I would rather recommend that.
tankergoblinCommented:
It seems like the connection already establish try to set longer time out.

see below link
http://forum.hostek.com/showthread.php?230-How-to-disable-FTP-timeout-in-Filezilla
tankergoblinCommented:
or disable timeout
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

KimputerCommented:
Without the passive ports  set in the firewall, timeout settings have no influence at all. It won't time out, but it won't show the directory listing either. It's NOT a solution.
abigulAuthor Commented:
Hi
Thanks for the comments:
In response to Kimputer: there is a firewall - ports 20 and 21 are allowed through, as are the passive ports. I tried filezilla server but was unable to connect so pursued ftp in iis.

In response to tankergoblin: I set the timeout to 0, the error now looks like this:

Command:      LIST
Response:      150 Opening BINARY mode data connection.
Error:      The data connection could not be established: ETIMEDOUT - Connection attempt timed out
Response:      550 Data channel timed out.
Error:      Failed to retrieve directory listing
Error:      Disconnected from server: ECONNABORTED - Connection aborted

Thanks
A
KimputerCommented:
Did you also properly forward the passive ports in your router?
tankergoblinCommented:
1) you prefer to use filezilla server or ftp IIS
2) how you do testing.
3) you test server and client in same machine
4) if possible briefly describe how you setup your machine.
tankergoblinCommented:
you key in correct ftp address, username and password? can you print screen error msg you get in filezilla client
tankergoblinCommented:
have you create a ftp directory folder?
tankergoblinCommented:
if you can access ftp via cmd then i think your firewall is correctly set. i think problem should go to filezilla client setting.
abigulAuthor Commented:
Hi,
In response to kimputer: I don't have access to router the server is a VM in Windows Azure. The following ports are open in Azure:
Control      TCP      7000      7000      -
FTP      TCP      21      21      -
FTPControl      TCP      20      20      -
HTTP      TCP      80      80      -
PowerShell      TCP      5986      5986      -
Remote Desktop      TCP      64930      3389      -
SecFTP      TCP      989      989      -

In response to tankergoblin: I prefer IIS ftp. I've tested locally and remotely with command line and remotely with filezilla client. Test server and client are different. I set the server up as per the link in my question:
http://itq.nl/walkthrough-hosting-ftp-on-iis-7-5-a-windows-azure-vm-2/

Thanks
abigulAuthor Commented:
Hi,
tankergobiln > there is ftp dir. Error is in my post further up..

A
tankergoblinCommented:
your ftp link should be something like ftp://adress

try to insert your ftp link to ie can you open your ftp?
KimputerCommented:
tankergobiln is wrong about the assumption that cmd is a good test for the firewall/router settings. Except that cmd doesn't support passive FTP, and therefore is NOT a good test for the firewall/router settings. The firewall/router NEEDS those passive ports allowed/forwarded.
So in Azure, you need to open those extra passive ports

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tankergoblinCommented:
this is how it goes,

1) make sure you correctly configure your ftp server
2) make sure you open port 21 on your server firewall and your router / firewall if that is the port you use for ftp
3) make sure your link for your ftp is correct , username and password
4) you should able to connect in your LAN
tankergoblinCommented:
try to connect your ftp client in your ftp server if you can connect locally but not remotely then that mean your port is not open
abigulAuthor Commented:
Hi,
I'll open the extra passive ports and update when done

A
abigulAuthor Commented:
Hi,
Have opened the passive ports but it makes no difference. The error is the same. I installed filezilla client on my server and when I try to connect to the ftp site 127.0.0.1 I get exactly the same error as when connecting remotely. Does this then indicate that open ports are not the issue?

Thanks,
A
abigulAuthor Commented:
Thanks deleted ftp sites and re created using link from my question. Re created ports in Azure and it worked.

Thanks for pointing me in the right direction.

A
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.