Exchange 2013 Delegate Meeting issue

Hi,

I have a MD who's is having issues with their delegate permissions.
When ever they receive meeting requests it reports the following,
"The meeting request has been sent to your delegate(s). Your delegate has not responded to this meeting.

It reports that "No Response Required"
It doesn't appear to allow the MD to accept any meeting requests, it only allows their PA, which is the delegate.

The delegate "PA" has Send As, Send of Behalf, and Full Access to the MDs mailbox set from Exchange ECP.

Their delegate permissions have also been set from the MDs Outlook mailbox.
The "PA" has editor permissions on the Calendar, Inbox and Contacts.
And the checkbox "Delegate receives copies of meeting-related messages sent to me"

What have I missed?

This is just a typical Managing Director/ Personal Assistant scenario.

I want the PA to be able to access the MDs Inbox, Calendar and contacts, Send and respond to email on the MDs behalf.
Action meeting requests, but I also want the MD to be able to action meeting requests as well.

Any ideas?

Outlook 2013 Delegate settingsExchange 2013 Delegate settingsExchange 2013 Delegate settingsOutook
LVL 1
Tech ManAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

systechadminConsultantCommented:
it seems that you might have some "ghost" delegates left on the mailbox. Please Use ADSIEDIT to look at PublicDelegates.
If its fine then remove the option

Open Outlook > Select Tools > Options > Delegates > Delegate name > Permissions and remove the tick in the box "Delegate receives copies of meeting related messages sent to me.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Murali ReddyExchange ExpertCommented:
In the delegates tab of MD, choose "My delegates and Me" when both MD and PA needs to accept the invites.
delegate.JPG
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.