How can I check for logs that pertains to NTP on a system?

We have Domain Controllers configured as NTP. My Info Sec department want me to validate that the DCs are indeed configured as such. I did not configure the DCs so I wouldnt know where to check to validate this. Are there certain logs that I can check within the DCs to determine this?

Also, how can I send those logs to Splunk?
joukiejoukAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zephyr ICTCloud ArchitectCommented:
A quick way to check if NTP is configured on your server is to run something like this in a cmd window:

w32tm /monitor

Open in new window


It will show details of which server/device it's synching with, if any.

The "logs" of ntp are in the Windows Eventlog, you can send/catch these eventlogs with Splunk, but it will require some doing to filter out just the NTP entries, more info here

You could look for Event ID 12 and/or 29 ... There's more Event ID's for NTP though, check here for a small list.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
joukiejoukAuthor Commented:
I am not able to RDP into a sub-set of machines to run the w32tm /monitor command due to firewall restrictions that those machines reside on. Is there a way I can do it via a back end to run the w32tm /monitor on these machine?
0
Zephyr ICTCloud ArchitectCommented:
Unless you have a way to remotely connect via another way I doubt it... You could create a script that runs at login and sends the results to you by mail ...
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

joukiejoukAuthor Commented:
I ran the command on a particular machine and received the following:

2015-07-08-9-03-57.png
What does this indicate, and how can it be resolved?
0
Zephyr ICTCloud ArchitectCommented:
Most likely NTP isn't configured on your server, now to configure it you can do it manually using this Microsoft site  or use the fix it for me but that's maybe not a good idea on a server.

You can choose to use an external source to sync with or an internal...
0
joukiejoukAuthor Commented:
Let me clarify, I ran that command from a workstation on a particular network segment. However, when I run the same command on my computer (on a different network segment), it finds the NTP server just fine. Our DC's is configured for NTP. I think it's just a particular network segment where that workstation resides on that is failing to snyc with NTP. Or, maybe it's the workstation. I'd like to see if maybe I can do anything from the workstation first to have it sync with NTP. Any suggestions?
0
Zephyr ICTCloud ArchitectCommented:
Aha, ok ... Sorry about the misunderstanding...

If you can connect to the ntp server via a telnet on port 123 (eg: telnet 10.10.10.1 123)  then there's no problem with the NTP itself probably ... Maybe there's something blocking the access to it, like a firewall or router or something?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Network Management

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.