Exchange Attachment Corruption, HTTPS Download Errors

We've got a dedicated server in a data centre running Server 2012 R2 / Hyper-V with two VMs. It's only been live for a month.

There's only one NIC and the host OS is running RRAS to provide network connectivity to the VMs.

What we've noticed over the last week or so is that Exchange attachments are coming through as corrupt on occasion. We did a byte-comparison between the "corrupt" attachment and a proper copy and found about 10 bytes difference total between the two files (3mb in size) and the differences were evenly spread throughout the file.

Another issue we've noticed is that HTTPS downloads immediately fail on the VMs (but work fine on the host OS). I've installed all relevant hotfixes regarding TLS issues so I don't think it's Microsoft update related.

I ran WireShark to check what's happening with the HTTPS downloads and found that there were errors during the TLS/HTTPS transfer with warnings like "the acknolwedgement number field is nonzero" and ACK/RST errors.

I guess it feels like there's some sort of network corruption but we've tried updating the drivers on the host for the network card, turning off all acceleration &  task offloading, applying all outstanding Microsoft updates, rebooting numerous times and so on.

I tested the hashes on straight HTTP downloads on the VMs out of curiosity (downloaded a fedora ISO of 2GB) and it checked out fine against a SHA256 hash.

Really at a bit of a loss here, if anyone can throw their two cents in it would be greatly appreciated. Thanks!

--

An update:

We killed RRAS on the host and made the DC VM internet-facing then setup RRAS on that DC so that the TS would use it for internet access. What we found is that the DC then became able to download over HTTPS however the TS still cannot.

It seems that RRAS is potentially causing some sort of network corruption or packets to be malformed or something. Anyone have any input?
MindspheresAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Robin CMSenior Security and Infrastructure EngineerCommented:
I've had issues with a Dell R710 and the default NIC drivers that came with Windows Server 2012 R2. Update to the latest NIC manufacturer drivers and problems solved. But you said you've already tried that.

Did you see this forum post, sounds similar: https://social.technet.microsoft.com/Forums/windowsserver/en-US/ea061886-8140-4e3a-ad00-dc3dc98f3626/data-downloads-corrupted-by-windows-server-2008r2-using-nat-on-rras?forum=winserverNIS
They reckoned it was something to do with the ISP.

They did mention MTU size, which I've had cause strange issues with certain routers that don't allow the negotiations to work properly. You could try setting the MTU low (say 900) on the VM with the problem and see if that makes any difference.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MindspheresAuthor Commented:
That seemed to work!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.