Problem with Windows 8.1 Apps

Hello,

I have the following problem on one of our notebooks.

Windows 8 Apps are minimizing automatically when starting, the icon remains in the taskbar, but when you click on it it shows the start screen of the app for a second and minimizing again.

The only apps which are working at the moment are the InternetExplorer and Photos, other apps like Reader are not working.

The problem has started two weeks ago, the apps have worked earlier without any problem.

There are no changes in GPO's in the time frame the problem occurs for the first time and it works well for other Win 8.1 computers. Also the computers are fresh installed with Windows 8.1 and not upgraded from 8.

Thanks in advance for any help

br
LVL 2
DavidSysadminAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Iamthecreator OMCommented:
Open up task manager click more details app history on top bar double click on the app that wish to open and It should open normally. After that you should be able to open apps from desktop.
0
Iamthecreator OMCommented:
If that doesnt work try this solution (backup the registry hive prior to changing it)
 actually found solution and it worked for me.

    Open Registry Editor using regedit.exe.
    Right click on HKEY_CLASSES_ROOT.
    Click on "Permissions" and in popup click on "Add".
    In 2nd Popup click on "Advanced".
    In 3rd Popus click on "Find Now".
    In "Search Results" click on "All Application Packages" and then click "Ok".
    Now in 2nd Popup "Select Users or Groups" click again "Ok".
    In Permissions select under Allow "Read" and Click "Ok".
    Close the Registry Editor. No need to restart.

Metro apps works again and never more minimize!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rindiCommented:
Use system restore to return back to the time it was still working.
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

McKnifeCommented:
See if it works for another user.
0
DavidSysadminAuthor Commented:
@McKnife - it does not work for another user, already tried this

@Rahul Misra - thanks I will try this

@rindi - not an option in this case, I want to know what causes the problem

thanks
0
DavidSysadminAuthor Commented:
@Rahul Misra, thanks, that was the solution, works perfect for me.

But you should also set the file system permissions  - see below. Because in some cases the problem also occurs when this permissions are wrong.

1) Go to program files (make sure "show hidden folders and files is on")
2) Right click on windowsapps and go to properties-> security tab->advanced
3)Click on continue to view the permissions of object
4) For the owner it will show TrustedInstaller, click on change
5) A new window will open->select object types->select groups and then click on ok.
6)In the space below "Enter the object Name", type ALL APPLICATION PACKAGES
7) Next press ok, it will take some time for the owner to change.
8) Last step is to restart your system.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 8

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.