DNS issue with DHCP turned on - no internet

A neighbor's laptop was having problems connecting to the internet so I'm trying to diagnose and fix the problem.
Her Windows 7 laptop is normally configured for DHCP for ip and dns.
She recently allowed her laptop to receive a bunch of Windows updates but she's not sure that the updates correlate with when the problem started.

I've got the laptop at my house and it will only connect to the internet when I change DHCP to my ISP's DNS.  I can leave DHCP on for IP address but DNS must be static otherwise it connects to my network (wired or wireless) but never can get to any web pages or her outlook email doesn't work.  Plug in a static DNS and viola, it works.  We are both on the same ISP (TWC Roadrunner Austin).
I might also mention, when I'm go back to wireless on this laptop, it takes about 1 minute before the signal bars at the bottom clear (no spinning circle).  It still doesn't connect, but it's odd that it takes so long to try to establish a connection and I thought that might be helpful info.

My DHCP works well for the 10 other devices in my home that regularly connect to my wireless network so I've kind of eliminated my WNDR3700v4 router as a possible problem.  I haven't done a system restore (yet), because I wanted to try to figure out the problem first if possible.

Would appreciate some troubleshooting tips before doing a system restore attempt.
BRIDGEDIVISIONAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
DHCP and DNS are different animals.  Try resetting TCP/IP.

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache
Then restart the computer

You should also look in c:\windows\system32\drivers\etc\hosts and see if there are any bogus entries in the hosts file.
tankergoblinCommented:
Do you use DC in your network?
BRIDGEDIVISIONAuthor Commented:
Thanks John, I will look into that when I get home later today.

tankergoblin, sorry, what is DC?
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

JohnBusiness Consultant (Owner)Commented:
DC is Domain Controller and you probably do not have a Domain Controller here
BRIDGEDIVISIONAuthor Commented:
oh. duh. no, I don't use a domain controller on my home network.
tankergoblinCommented:
then you can try to set secondary dns in your router or manually configure it in the problem pc. you can try to use 8.8.8.8 as your secondary dns.
BRIDGEDIVISIONAuthor Commented:
When I configure a static DNS IP in the problem pc, it consistently works and connects to the internet/mail, etc.

My router is already set up with googles DNS address as secondary and my ISP's DNS as primary.
tankergoblinCommented:
then you try ipconfig/flushdns as suggested by John see whether your problem solve ?
BRIDGEDIVISIONAuthor Commented:
John Hurst, I tried all of the steps you listed, but it made no difference at all.

I put google servers in the dns and immediatly worked.  I also used public domain dns servers or my roadrunner dns servers, and it always works after that.

There must be something I'm overlooking.  By the way I have a router with DHCP turned on and an access point with DHCP turned on. I've connected to both with DHCP, it makes no difference, won't work until I plug in a valid dns ip.
Same thing happens when I hardwire connect to my router, it wants a physical dns addy.
JohnBusiness Consultant (Owner)Commented:
There may be something wrong with the operating system at this point.

Try SFC. Open cmd.exe with Run as Administrator and run SFC /SCANNOW. Allow to complete, shut down, start up and test.

If no, run Windows 7 Repair install. For this, you need a working recovery partition, or the Windows 7 DVD. Here is a Seven Forums tutorial to assist you.

http://www.sevenforums.com/tutorials/3413-repair-install.html

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JustInCaseCommented:
If it is router WNDR3700v4 under DHCP config under
internet setup
select
use these DNS
and add
8.8.8.8
or whatever you want as primary and secondary DNS server
DNSThat should force that DNS be assigned through DHCP.
BRIDGEDIVISIONAuthor Commented:
John Hurst, SFC ran it's course but didn't find issues.  I would consider using Windows 7 repair as my last resort but another thought occurred to me... I powered up my own laptop and turned on DHCP (normally I have a static IP for everything).  My own laptop couldn't access internet sites until I added physical DNS addresses.
So my direction started turning to my router.

Coincidentally another poster (Predrag...) mentions this in the post after yours. I am going to investigate that at the moment.
BRIDGEDIVISIONAuthor Commented:
Predrag,
I'm not at home now but will try what you are suggesting later.  I have a sneaky suspicion this might work.
If it does then I'd ask why I have to plug in dns numbers into my router when all of that should be coming from my ISP (TWC in my case).
My router is setup the way your screen shot depicts, defaulting to get everything from ISP. This seems to work for 3 android tablets I use regularly at home to get to the internet, surf, check mail, etc. and those devices all use DHCP totally.
The only difference is my laptop is windows 8 and tablets are android.
JustInCaseCommented:
In a last few months I had problem with providers here in my area, for some reason their DNS servers did not work (or client routers did not get DNS from ISP's servers), so I forced on many routers in a last few months to use google 8.8.8.8 and Level 3 Communications 4.4.2.2 as DNS.
And truth to tell many of those routers worked for years without bigger issue (except need to restart sometimes) and than at one point in time problems started, so far about 30 routers from home clients had the same issue pattern as your case.
BRIDGEDIVISIONAuthor Commented:
I may also try to hardcode my ISP's dns server numbers into the router as well but google's DNS addresses should be ok too.  Thanks
BRIDGEDIVISIONAuthor Commented:
Predrag, it sounded like a good idea but it didn't work.
I used google dns servers and tried TWC's DNS servers, even tried OpenDNS servers, but it didn't change anything so I went back to the default 'get automatically from ISP" setting.

I also verified that my 3 android tablets can get out to the internet and they're all DHCP.  So I guess this points back to my laptop.
BRIDGEDIVISIONAuthor Commented:
It didn't fix my issue but it helped.
JohnBusiness Consultant (Owner)Commented:
Thanks and I was happy to help you.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DHCP

From novice to tech pro — start learning today.