SCCM 2012 R2 upgrade to SP1 - SQL Error Message

Hello

I am trying to upgrade our SCCM 2012 R2 server to the recently released SP1.  When i run through the installation, i get to the first "Before You Begin" page, click Next and I then receive the following error message:

The SELECT permission was denied on the object 'SetupInfo', datavase 'CM_EUR', schema 'dbo'.

I'm currently logged into the server as a domain admin, and have full access to the console.

I've had a look through SQL and can't even see 'SetupInfo' but when running Select on other items I can access fine.

Any ideas how to get around this?

Thanks
ScreenHunter-193-Jun.-24-16.27.jpg
LVL 1
WolfAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Nagendra Pratap SinghDesktop Applications SpecialistCommented:
Login with the same account which was used to install SCCM. If it was set correctly then it will have rights on the local system as well as SQL>
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Deepak ChauhanSQL Server DBACommented:
First connect SQL server usign sysadmin user and see if the login exists in sql from which you are running setup. if this login exists check the permissions if not add this login.

Connect SQL server using SSMS with sysadmin account or at least user which have DB_Owner permission on the database CM_EUR. expand this database > Table folder and find the table 'SetupInfo'. If you can see this table this means respective user does not have permission then grant permissions:
Grant select on schema:: DBO to <username> 

Open in new window


If you are not able to see with sysadmin or db_owner rights this means table does not exist in the database.

You can query system view to find the table.

Use CM_EUR
go
select * from sys.tables where name='SetupInfo'
 

Open in new window

0
Vitor MontalvãoMSSQL Senior EngineerCommented:
Take a better look on the error message:
"The SELECT permission was denied on the object 'SetupInfo', database 'CM_EUR', schema 'dbo'."

It's really denied which means that if even you're dbowner you won't be able to select data from that table. Even that you are able to GRANT SELECT on the table the DENY permission is in an higher level so you'll still not able to query the table.
So, before you run the GRANT SELECT ON SetupInfo you first need to REVOKE the DENY on the same table for your user.
0
WolfAuthor Commented:
Perfect, this worked correctly now - many thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server Apps

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.