Power on Virtual Machine error message

ESXi 5.5, tried to power on new vm. Received this message...

Heap globalCartel-1 already at its maximum size of 7869288. Cannot expand.
Could not start VMX: msg.vmk.status.VMK_NO_MEMORY

Hp Proliant DL 360p Gen8
eliaexpertsAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
This is to be expected because the datastore the VM is stored on, or the datastore the VM SWAP file resides on does not have enough storage space for the swap file.

When a VM is powered on the hypervisor creates a SWAP file equal to the RAM defined in the VM. (or reserved memory size).

Solution, free up space on the datastore, I would recommend keeping at least 20% free on the datastore for swap files and snapshots.

How much free space do you have on the datastore ?

You can also move the SWAP (VSWP) onto a new datastore with free space.

see also here

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2030250
eliaexpertsAuthor Commented:
Thanks for the response.  But my error message is different, though I did free up space with no avail.
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
In this case, it's because of a HP AMS memory leak fault see here

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2085618
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

eliaexpertsAuthor Commented:
Created a total new install for this VM and it worked.  Thank you for the suggestions!  FYI...we had trouble executing the suggestion regarding the memory leak.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
eliaexpertsAuthor Commented:
Not sure I totally understand what happened here.
detox1978Commented:
I have the same issue here

There's only one datastore and it's got loads of free space.  There's also plenty of available RAM.


Any suggestions?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.