Netscaler Load balancer & secure Virtual Directory

Hi, im running Windows 2012 R2 with IIS 8.5. i have created a virtual directory on my IIS and enabled SSL just for the Virtual Directoty. I have disabled anonmous authentication and enabled basic.
If i connect directoy to the VD over HTTPS it askes for a username and password, which if i enter it allows me access.

I have a netscaler VPX appliance configured as a Load blancer and SSL offloader. i have a service configured on the netscaler which accepts port 80 & 443 and forwards the traffic to the IIS server in question so at the moment a direct 1:1 relationship.

The issue is that if i try and access the VD via the netscaler i just get a 403 forbidden. looking at the IIS logs i can see the connection between netsclaner and the IIS server is over port 80 and not 443 and im guessing that the Netscaler is offloading the 443 peice.

any ideas on how to acheive this as the website itself is set up as standard port 80, its only the VD which requires port 443.

thanks
synergytecHead of ITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dan McFaddenSystems EngineerCommented:
Can you post a section of the http logs from when you are getting the 403?

Dan
0
synergytecHead of ITAuthor Commented:
Hi,

i think i fugured out the issue. when the request was hitting the IIS server and moreso the virtual directory, the request was coming in with port 80 and not 443. i amded my virtual directory to uncheck SSL as this was being handled by the netscaler and set the folder with basic authentication. i also disabled anonymous. this resolved the issue as the client request remains HTTPS. thanks for your help.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
synergytecHead of ITAuthor Commented:
Solution worked without too much reconfiguration.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.