CRM 2011 server is not working properly after install of Rollup 18

I have CRM 2011 and the MS SQL server hosting the CRM database on a single server installation  (OS: MS Server 2008 R2) .

I attempted to install Rollup 18 (the CRM installation was at Rollup 8) which failed. Attempting to access CRM via the web interface came up with Unexpected Error.

I tried updating again and this time the install went in, but I still have the error, and even uninstalling the updates hasn't fixed it.

I can see the CRM server and it's services working, SSRS and Reporting Extensions are installed, the MS SQL server is running and the CRM database and Config database are present. I can even run reports through SQL Server Business Intelligence Development Studio.

However, the Deployment Manager has the messages 'Reporting is not enabled' and 'One or more server roles are missing from this deployment', specifically the 'Full Server' role when I open the message. However, when I look at the Server list in the Deployment Manager it says that I have Full Server, SRS Data Connector and SQL Server roles.

Somehow the CRM server has lost contact with the SQL server, and I don't know how to get them to talk to each other again.
Andrew LanghammerDatabase AdministratorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Feridun KadirPrincipal ConsultantCommented:
Hmm, not a nice position to be in. I suggest you navigate to Add/remove programs, select CRM Server 2011 and then click Uninstall/Change, But I'm not proposing an uninstall at this stage.

Click Configure in the new window to check which roles appear to be installed. If it is not Full Server then select the missing ones. If it is full server then cancel back and then select Repair.

If that doesn't work, then I would consider an uninstall and reinstall (but select connect to an existing deployment).

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Andrew LanghammerDatabase AdministratorAuthor Commented:
That did it. I never considered simply running Repair from the Programs and Features list. I guess I was looking too hard for a solution inside the application tools themselves. Take many points.
Feridun KadirPrincipal ConsultantCommented:
Great news. Glad you got there. Now I wonder if you actually have UR18 properly installed or not. Perhaps best to leave it alone now.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Dynamics

From novice to tech pro — start learning today.