Tomcat6 in eclipse

Hi Experts,

Tomcat6 in eclipse used to run OK one small j2ee web app a while ago, but Tomcat is taking forever to startup.(it finally reaches timeout.)

This is what I see from the console and nothing further.

Jun 25, 2015 9:23:12 AM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\tools\jre6\bin;.;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:/Program Files/Java/jre7/bin/client;C:/Program Files/Java/jre7/bin;C:/Program Files/Java/jre7/lib/i386;C:\Program Files\PHP\v5.6;C:\tools\ruby\bin;C:\tools\OracleInstantClient\instantclient_10_2;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\PROGRA~1\IBM\CLIENT~1;C:\PROGRA~1\IBM\CLIENT~1\Shared;C:\PROGRA~1\IBM\CLIENT~1\Emulator;;C:\tools\PHP;;C:\tools\eclipse;
Jun 25, 2015 9:23:12 AM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.j2ee.server:oir' did not find a matching property.
Jun 25, 2015 9:23:13 AM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Jun 25, 2015 9:23:13 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 1167 ms
Jun 25, 2015 9:23:13 AM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Jun 25, 2015 9:23:13 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.39

I ping oracle DB, it works ok.
Where should I start?

thanks,
dkim18Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mccarlIT Business Systems Analyst / Software DeveloperCommented:
First try to increase Eclipses timeout for waiting for tomcat to start. At least on my system, with my webapp, the default setting just isn't long enough to get the app up and running.

Other than that, it's a bit hard to say from the limited info that you have. Those logs aren't anything unusual and so they don't really help.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gheistCommented:
Start tomcat without eclipse, than connect eclipse when all is deployed.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.