Exchange 2013 restricting email to "only senders inside my organization"

I'm running exchange 2013 and I'm trying to restrict DL's to only receive email from "only senders inside my organization".
I found the option, it's checked, but it doesn't work, as I have some emails failing wth the error "550. 5.7.1 Resolvever.rst"

That's because I had to turn off the option "externally secured" on one of my receive connectors.
If I enable the "externally secured', then anyone can send to the Distribution Lists again even though the option to "only senders inside my organization" is checked.  

I couldn't find a fix for this online, so perhaps I missed something?
DanNetwork EngineerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Amit KumarCommented:
Please check if "RequireSenderAuthenticationEnabled" property is checked or unchecked. If unchecked then please mark it checked, it will restrict mails to this DL from external domains.

Get-DistributionGroup <DLEmailaddress> | fl *require*

Open in new window

DanNetwork EngineerAuthor Commented:
comes back with:  requiresenderauthenticationenabled: true
Simon Butler (Sembee)ConsultantCommented:
Externally Secured is not normally enabled on Receive Connectors, as that turns the connector in to an open relay.

Are users sending exclusively via Outlook Anywhere, or do you have POP/IMAP users as well?

Simon.
DanNetwork EngineerAuthor Commented:
We have a setup with an external web server, that acts as an SMTP relay, so for 1 receive connector, I have to have the "externally secured" on, otherwise, when we send out our mass emails to everyone on our lists, the job doesn't run.   After I turned on the externally secured, it worked fine.

Not sure if there's a work around this problem?
Simon Butler (Sembee)ConsultantCommented:
If you have the connector locked down then you should be ok.

Personally I prefer to use the anonymous permission method as outlined in this Exchange 2010 TechNet article.
https://technet.microsoft.com/en-us/library/bb232021(v=exchg.141).aspx

Although the best solution if you are doing a bulk email run is to outsource it. Exchange is a very poor bulk emailing solution.

Simon.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.