Solaris 11 DHCP Server Problem - not passing DNS servers to clients

I have setup a DHCP server on Solaris 11.  However, when my client Windows PC's get an IP address all is set except the DNS servers.  When I run in.dhcpd in debug mode, the following is displayed:

" name service update on behalf of client with ID 010010A47C4E3F failed because requested name was not fully-qualified and no DNS domain name was specified for this client in the dhcptab"

What does this mean?  The dhcptab file contains:
pcidev|m|18347383406930690049|:Include=Locale:Timeserv=192.168.100.99:LeaseTim=86400:LeaseNeg:DNSdmain="pcidev":DNSserv=75.75.75.75 75.75.75.76:

pcidev is the server at 192.168.100.99.  From that server DNS works, clients picking up and IP from the DHCP server will not get the DNS server IP's.  Any ideas what I am not doing correctly?
djpriceAtlAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zephyr ICTCloud ArchitectCommented:
I think it means the FQDN of the pcidev is needed, as in pcidev.domainname.local for example ...

Can you run " check-hostname" on the pcidev device?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
djpriceAtlAuthor Commented:
It returns:
"Hostname pcidev OK: fully qualified as pcidev.pciinside"

However, this is after I manually edited hosts to add pcidev.pciinside.  For some reason, dhcp still is not picking this up?  It does successfully give out IP's and the correct default gateway but it leaves the DNS servers empty.
dhtadm -P returns:
192.168.100.0Macro:Subnet=255.255.255.0:Router=192.168.100.7:Broadcst=192.168.100.255:
pcidevMacro:Include=Locale:Timeserv=192.168.100.99:LeaseTim=86400:LeaseNeg:DNSdmain="pciinside":DNSserv=75.75.75.75 75.75.75.76:
Locale  Macro :UTCoffst=-18000:
0
Zephyr ICTCloud ArchitectCommented:
What is the result of "dhcpconfig -P" on the DHCP server, is it UPDATE_TIMEOUT?

Is the DNS server configured to receive updates from the DHCP server?

I'm wondering if the DHCP/DNS doesn't have to do with the single-space domain name.
0
djpriceAtlAuthor Commented:
Thank you for your help, I resolved the issue.  Your help with pointing me the check-hostname helped to eliminate what DNS was telling me it thought it was.  I unconfigured dhcp, then reconfigured it adding the IP addresses with the dhcpmgr tool.  I saw the DNS servers were missing from the network macro so once I added them there, all worked.
0
Zephyr ICTCloud ArchitectCommented:
Awesome, glad to get you to the solution ;-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DHCP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.