Changing default email account on IPhone 4g

I have been trying to change me email default account  on IPhone 4g without success. Can someone give me clear instructions?
Michael MurphyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Michael HughettICT Field Systems AnalystCommented:
Go to settings - Mail, contacts, calendars - scroll down to default account.
Michael MurphyAuthor Commented:
I have been following those instructions for some months now but although the new email address is ticked in Settings as the default account I still cannot send mail from it. I have to revert to the unwanted account to succeed. Now this unwanted (as my default) email account is icloud . I've just tried  to change it again. No luck
Eoin OSullivanConsultantCommented:
Mike

Could it be that the Outgoing SMTP mail settings for the email account are not setup correctly?

Go to the list of Accounts in the Settings -> Mail, contacts, calendars and click on the mailbox that you are having the issue with.

Open the mailbox and click on the Account section inside to get to the detailed settings.
Look at the Outgoing Mail Server Settings SMTP and open it ..  disable all other SMTP servers then click on the Primary Server ... check that all the settiings are correct hostname/username/password/port etc.  If these setttings are correct you SHOULD be able to send emails from this account.  It is not uncommon for certain mail accounts to use different ports for outgoing mail than the default and until these settings are correct you'll not be able to SEND email from the new mailbox.

Now when you send a NEW email (rather than reply to a received mail) it should be sending from your new email account.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Michael MurphyAuthor Commented:
That did the trick. The email account that I was trying to use was disabled. i enabled it and it worked and I was able to send emails. Thanks
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
iPhone

From novice to tech pro — start learning today.