Windows 8.1 Tablet Screen Timeout

I recently purchased a new Windows tablet hybrid. Specifically, this one:


For reasons that simply escape me, this thing shuts off the screen after like 1 or 2 minutes regardless of what I set in the Power Plan Settings. Is there a magical setting that I need to adjust in order to make the screen timeout less frequently? As a slow reader, it's frustrating when the darn things shuts off the screen in the middle of a paragraph!
LVL 75
käµfm³d   👽Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
First, for Windows, make sure there is no screen saver and that you have double checked Turn off the Display is set to a long time.

Second, look in the BIOS to see if there is a setting to turn off the screen.

Third, ask the supplier to take it back. The screen should remain on as long as you are using it regardless of the Turn Display off value.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Michael DyerSenior Systems Support AnalystCommented:
I think this sounds like a hardware issue - I'd return that unit for a replacement.  It has to be under warranty.
käµfm³d 👽Author Commented:
I bought it at Costco, so I'm sure they'll replace it its defective.

So my screensaver was set to "None", and it had a value of 1 minute. All my previous experience with Windows tells me that this would suffice. However, leaving it a "None" and bumping the timeout up to 10 mins seems to have cleared it up. Weird.

Thanks!
JohnBusiness Consultant (Owner)Commented:
@käµfm³d  - Thanks for the update and I am glad that settings fixed it in the end.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 8

From novice to tech pro — start learning today.