Performance issues after migrating to a new server with better hardware config

Hello,
I need help optimizing a server. We are currently using a pc with below configuration as a server (current) for Sugarcrm.

Processor: Intel i7-4770K
RAM: 16GB
Hard disk: SATA 500GB 7200 rpm
OS: Ubuntu 12.04 LTS
SugarCRM version: 6.5.10 CE
DB: mysql
DB size: Around 5 GB

Since the number of users were increasing we thought of migrating to a server (new) based hardware with below configuration

Processor: Intel Xeon E5-2630v3 8 core x 2
RAM: 16 GB DDR4
Hard disk: SAS 1 TB Raid
OS: Ubuntu 14.04 LTS
SugarCRM version: 6.5.10 CE
DB: mysql
DB size: Same as above

Surprisingly, the same lead takes about 4.5 seconds to open on current i7 pc but takes about 12 seconds on the xeon server. The xeon server currently does not have any users connected to it as we are unable to resolve the issues related to performance.

We even tried taking a clone of the current server but didn't help.

We've spent about 20 days trying to optimize it but are still unable to do the same. Could anyone please suggest how we can identify what the bottleneck might be.

When we put the same hard disk on the current machine it works absolutely fine. Only when we use the new server it causes issues.

I'm attaching a top command screen shot for reference.

Any help would be greatly appreciated. Thanks in advance.
crm-top-command.PNG
orazen11Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Gerwin Jansen, EE MVETopic Advisor Commented:
Is your Apache on the old machine using 85% CPU as well?
No swap is used so that would not be an issue (memory usage that is).
orazen11Author Commented:
Actually this server does not have any load at all. The top command is just a snapshot. So maybe at that time it was consuming 100%. However, I'll verify this and reply here.
D_VanteCommented:
Check to see whatelse was installed with the Server OS
Your OS and DATA and if possible your Web should be on different RAID sets
Check for latest network drivers and other drivers as well, including video

What RPM are the new drives?
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Preston CooperDatabase AdministratorCommented:
What RAID Level are you using?
Gerwin Jansen, EE MVETopic Advisor Commented:
No more feedback? Issue solved?
orazen11Author Commented:
Sorry for the delay in response. We tried a new approach and it worked.

Intel guys had told us to use Ubuntu 14.04 so we had our existing 12.04 to 14.04 using the CLI. So we tried with a fresh installation of 14.04 and configured it from scratch and it started working.

Thanks all for your help and support.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Gerwin Jansen, EE MVETopic Advisor Commented:
>> Sorry for the delay in response.
No problem at all, good to hear that it's working for you now.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Hardware

From novice to tech pro — start learning today.