Exchange 2013 Certificate error

Hi All,

OK, I have installed on a clean server, a fresh, clean installation of Exchange 2013 (CU8).

The local network is running on a .local

As I've done many times before, once I've done the initial setup of Exchange, there are the powershell commands that I execute to rename the virtual directories.

Set-ClientAccessServer -Identity "DWEX" -AutodiscoverServiceInternalUri "https://owa.domain.com/Autodiscover/Autodiscover.xml"
Set-OABVirtualDirectory -Identity "DWEX\OAB (Default Web Site)" -InternalUrl "https://owa.domain.com/OAB"
Set-WebServicesVirtualDirectory -Identity "DWEX\EWS (Default Web Site)" -InternalUrl "https://owa.domain.com/EWS/Exchange.asmx"
Set-ActiveSyncVirtualDirectory -Identity "DWEX\Microsoft-Server-ActiveSync (Default Web Site)" -InternalUrl "https://owa.domain.com/Microsoft-Server-ActiveSync"
Set-OWAVirtualDirectory -Identity "DWEX\owa (Default Web Site)" -InternalUrl "https://owa.domain.com/owa"
Set-ECPVirtualDirectory -Identity "DWEX\ecp (Default Web Site)" -InternalUrl "https://owa.domain.com/ecp"

These all executed successfully

I've obtained a certificate from a 3rd party and the SAN names featured are owa.domain.com, autodiscover.domain.com etc

OWA both internally and externally works fine (no certificate errors).

Outlook 2013 clients do autodiscover as expected, but the Outlook gives a certificate error when we start Outlook every time.

"There is a problem with the proxy server's security certificate.  The name on the security certificate is invalid or does not match the name of the target site dwex.dw.local.  Outlook is unable to connect to the proxy server (Error Code 10)".

dwex.dw.local is the Exchange server name.

Clicking OK clears the error and Outlook continues to work fine.

I've done this setup a number of times but never encountered this error.

Running "get" commands on the virtual directories all return the expected directory name (ie https://owa.domain.com... etc)

When clients ping owa.domain.com, it returns the correct LAN IP address.

Any ideas?

Thanks in advance!
JamieD71Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
I don't see the change to Outlook Anywhere.
Exchange 2013 only uses Outlook Anywhere for connection.

The other option is to do an Autodiscover test and see what URL you missed.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JamieD71Author Commented:
Hi Simon,

Reading into this, it seems as though I need do need to modify these.

I ran get-outlookanywhere and it returned ExternalHostname as owa.domain.com but the InternalHostname was dwex.dw.local.

Should InternalHostname also be owa.domain.com, bearing in mind that I've got split DNS and internal clients do resolve owa.domain.com against dwex.dw.local...

But digging around, the suggestions seem to be something along the lines of
Set-OutlookProvider EXPR -CertPrincipalName MSSTD:owa.domain.com

This sound right?  Should it also be set for EXCH as well?

Thanks again and I'm impressed with a Sunday response :)
0
Simon Butler (Sembee)ConsultantCommented:
You need to do both the internal and external URL. I would also do the set-outlookprovider as well.
The Autodiscover test is key here - that will tell you whether you have missed anything.

Simon.
0
JamieD71Author Commented:
Hi Simon,

All resolved.

What actually prompted me was your site here:  http://exchange.sembee.info/2013/install/clientaccesshostnames.asp and in particular, the checking of Outlook Anywhere URLs (and autodiscover).

I'm somewhat baffled, since I distinctly recall setting the correct internal URL...  And I don't know why it changed...

Many thanks for your help here and on your site :)

Cheers,


Jamie
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.