SQL Server BCP Command not working on one Windows 8 instance

I have identical Windows 8 pcs running SQL Server 2012 Express. Each evening, a dos batch file is run to export data to text files which are then uploaded to a 'central' server for import / collation.
Having just swapped a dead pc for another identical one, I've found that the batch file command BCP is giving an operating system error 'The BCP bulk copy command is no longer working' and stops. The error details are below which relate to odbc32.dll and I'm unable to find any details so far. The batch file has been copied from an existing (working) system and I've never had this when setting up the other pcs in the past.
A typical bcp command I'm using is as follows (there are 5 bcp commands in the file and they all give the same error).

bcp "execute usp_export_log" queryout %filename%_log.csv -U sa -P %password% -S .\SQLEXPRESS -d {database} -c -t"," -r"\n"

Open in new window


Any help appreciated!

Problem signature:
  Problem Event Name:      APPCRASH
  Application Name:      bcp.exe
  Application Version:      2011.110.2100.60
  Application Timestamp:      4f35eb49
  Fault Module Name:      ODBC32.dll
  Fault Module Version:      6.3.9600.17415
  Fault Module Timestamp:      5450504d
  Exception Code:      c000001d
  Exception Offset:      000000000005f734
  OS Version:      6.3.9600.2.0.0.256.48
  Locale ID:      2057
  Additional Information 1:      6919
  Additional Information 2:      6919bebc82318cbafee4b507f3eaefa9
  Additional Information 3:      d934
  Additional Information 4:      d934b3be743cbcde52d9c76d2826373d
nigelr99Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Deepak ChauhanSQL Server DBACommented:
Is any error in windows error log stating like

The ODBC resource DLL (c:\windows\system\odbcint.dll) is a different version......
0
nigelr99Author Commented:
There is nothing obvious relating to this in the event log. I've tried un-installing and re-installing SQL Server and all pending Windows updates out of desperation but still the same. I ran SFC /SCANNOW as well and even though it reported some fixes it hasn't made any difference to the BCP command.
Any further ideas please?
0
Vitor MontalvãoMSSQL Senior EngineerCommented:
Can you reinstall BCP?
0
nigelr99Author Commented:
I've since found that I get the same error with sqlcmd so out of desperation, I again un-installed SQL Server completely, rebooted and re-installed. Unfortunately, I still get the same error :-(
0
Vitor MontalvãoMSSQL Senior EngineerCommented:
No good news then. Sorry but I can't see better alternative than reinstalling the operating system.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.