VLan on ASA 5510 can not get to the internet.

I can not get my VLan (Ethernet0/3.16) to access the internet via (Ethernet0/2)

I can ping out from the ASA to the internet via (Ethernet0/2) but cant get out over the Vlan at all.   The ASA also hands out the DHCP for the VLan and i have double checked everything there as well.

Help Please!!!
LOGTECHSERVAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JustInCaseCommented:
Did you create NAT rule for that VLAN, and did you double check default gateway for VLAN?
LOGTECHSERVAuthor Commented:
Gateway is fine... I was thing it might be something with the NAT rule but not sure what the setting should be,
Don JohnstonInstructorCommented:
It would help to see a (sanitized) config.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

LOGTECHSERVAuthor Commented:
Here Ya Go :)  FYI interface Ethernet0/0 & interface Ethernet0/1 Will be a second ISP and Network im going to add in later.

interface Ethernet0/0
 shutdown
 nameif Staff-ISP
 security-level 0
 no ip address
!
interface Ethernet0/1
 shutdown
 nameif Staff-Network
 security-level 0
 no ip address
!
interface Ethernet0/2
 nameif Guest-ISP
 security-level 0
 ip address X.X.X.X 255.255.255.240
!
interface Ethernet0/3
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/3.16
 vlan 16
 nameif Guest-Network
 security-level 0
 ip address X.X.X.X 255.255.255.0
!
interface Management0/0
 management-only
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
boot system disk0:/asa916-k8.bin
ftp mode passive
dns domain-lookup Guest-ISP
dns domain-lookup Guest-Network
dns server-group DefaultDNS
 name-server X.X.X.X
 name-server X.X.X.X
object network Guest_Network
 subnet X.X.X.X 255.255.255.0
object network Guest-NAT
 host X.X.X.X
access-list Guest-Network_access_in extended permit ip X.X.X.X 255.255.255.0 X.X.X.X 255.255.255.240 inactive
pager lines 24
logging enable
logging asdm informational
mtu management 1500
mtu Staff-ISP 1500
mtu Staff-Network 1500
mtu Guest-ISP 1500
mtu Guest-Network 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-742.bin
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (Guest-Network,Guest-ISP) source dynamic Guest_Network Guest-NAT destination static Guest-NAT Guest_Network net-to-net
access-group Guest-Network_access_in in interface Guest-Network
route Guest-ISP 0.0.0.0 0.0.0.0 X.X.X.X 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http X.X.X.X 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
no ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
dhcpd address X.X.X.X-X.X.X.X management
dhcpd enable management
!
dhcpd address X.X.X.X-X.X.X.X Guest-Network
dhcpd dns X.X.X.X X.X.X.X interface Guest-Network
dhcpd lease 1800 interface Guest-Network
dhcpd option 3 ip X.X.X.X interface Guest-Network
dhcpd enable Guest-Network
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
: end
Don JohnstonInstructorCommented:
There's a "same-security-traffic" command that is required if you want traffic to pass between interfaces with the same security level. Not sure if it's needed for level 0 interfaces though.
LOGTECHSERVAuthor Commented:
I tried that still no internet.
JustInCaseCommented:
The following example configures dynamic PAT that hides the x.x.x.x network behind the outside interface address:

(config)# object network my-inside-net
(config-network-object)# subnet x.x.x.x 255.255.255.0
(config-network-object)# nat (inside,outside) dynamic interface

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LOGTECHSERVAuthor Commented:
OK got that entered... Still cant get out... do i need to add any access rules?

Thanks!!!!
LOGTECHSERVAuthor Commented:
Need to Change Security Levels as well.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.