Active Directory Services Won't start. DNS has no domain informaton

We recently installed Active Directory services on a member server (small client that has only 1 server).  Everything went fine (dcpromo and all that good stuff).  This is Windows 2008 R2 Standard.

For several weeks everything was fine, then Active Directory Services stopped.  If you try to restart, it fails, yet nothing is logged in the Event log.  Very puzzling.  DNS has no entry for the domain.  If I try to run Dcpromo again, it does list the domain.local that was present, but can't start it again (since there is no DC to query).  tried to regtlibv12 actieds.tlb to no avail.

Any suggestions?
KPI1Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Will SzymkowskiSenior Solution ArchitectCommented:
So the domain is like it never existed?

Have you taken a backup of the Active Directory server using a System State backup?

Will.
KPI1Author Commented:
Yes, it's like it never existed.  We hadn't yet taken a backup.  We were just about to implement our backup device but this occurred first.  I really want to avoid creating a new AD, everyone getting new profiles, etc.
Will SzymkowskiSenior Solution ArchitectCommented:
Did someone do a restore or system resotre to an eariler date on this machine?

If this is your old DC in the domain then you will need to restrore it from backup.

Will.
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Seth SimmonsSr. Systems AdministratorCommented:
is it pointing to itself for dns?
have you looked at event logs?  i would go back to see when these problems began and try to figure out if someone changed something at that time
F PCommented:
OOoooooh my, I've been down this road before when testing DR with Backup Exec Veritas on bare metal restores using VMware with a replicating AD domain. I think I know where you should start. Honestly the first place you should look is the disk itself. Make sure it hasn't run out of space. Then look into the NTDS database and verify permissions and fragmentation, and finally check the NTDS Replication configuration and rebuild the replication configurations on both sides using replmon. Try those first., especially replmon to help you track down things.
KPI1Author Commented:
Had to completely redo AD.  Made an immediate backup afterwards.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
KPI1Author Commented:
Nothing else worked.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.