C Compiler for SCO Openserver 5.0.5

I am using SCO Openserver 5.0.5 and am trying to install a Moxa Nport N5110A Serial Device Server to run a printer.
Part of the install is to run 'make sco'.  When I do so I get 'make cannot find'

I have installed gcc, gnu tools & make which I downloaded from the net, but when I try running make I get a long list of files/directories not found.

I have attached the 'tar' file for the install.  If you vi Makefile there is a line for make sco 'cc -0' etc. That's where I get the error.

I need something that will allow me to complete the install

Harry
moxattyd-3.5-build-11032510.txt
sco505Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mikelfritzCommented:
Looks like you need to install system libraries:

http://www.sco.com/skunkware/devtools/#gcc
sco505Author Commented:
Hi
Thanks for that.  I have downloaded and installed both gcc-2.95.2-VOLS & Make-3.78.1-VOLS, but they didn't help.
Have I used the wrong files? Is there something I've missed?  Am I an idiot?

You're basically talking to a dummy novice about this

Harry
mikelfritzCommented:
The part I was talking about was this:

[Important Note for OpenServer Users]: The GCC package for OpenServer requires system libraries and headers. Even if you do not have a licensed Caldera development system, you are licensed to use these at no cost and they are available on your installation media. Install them thusly:

Invoke custom
Select "Install New" option from the "Software" menu.
Follow the prompts to steer custom toward the original media you used to install OpenServer 5.
Select Application Development Libraries and Linker. Install it all. This will give you the libraries, headers, and man pages.
Introduction to R

R is considered the predominant language for data scientist and statisticians. Learn how to use R for your own data science projects.

sco505Author Commented:
Did that and installed the Application Development Libraries & Linker.
Ran 'make sco' but got the same error.
So I thought I'd be smart and edited the Makefile file so the line for sco read 'gcc' instead of cc.
Ran 'make sco' again and after about 5 seconds the # prompt re-appeared with no errors.
I assume it worked.
Let you know if I can get the printer to work in a day or two
mikelfritzCommented:
Hopefully it worked.  I thought part of the SCO lib install was to link gcc and cc - could be the order in which things get installed.  This is a very old OS...

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sco505Author Commented:
Great job.  Finally got the thing working
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.