How can i run a .exe file on Centos?

I am trying to install WPS.exe (Airlive Wireless Projector Server), pls how do i go about it?
NIYIOKEAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
EXE files are Windows files only.  Have you checked to see if there is a UNIX installation file included?
0
andreasSystem AdminCommented:
You might try to setup WINE. its a windows environment running on linux, that will provide limited support for windows executables on linux.

Proper setup is however quite tricky. Im not into that so I cant assist on HOW to configure WINE correctly.

An other way might be to install windows into a virtual machine that is running on that linux host and let the exe run there.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
NIYIOKEAuthor Commented:
It doesnt have linux package. It is airlive wireless projector. if you access it with IP address on your LAN, you will just download the .exe file but mostly works for windows but i neet it to present on linux.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

TemodyPickalbatros, IT ManagerCommented:
You can use Crossover XI
https://www.codeweavers.com/products/
Very useful app easy to set-up and use
0
rindiCommented:
As already mentioned, you might get it to work via Wine, which is a windows emulator, and PlayOnLinux, which makes it easy to get windows files running under wine. I don't know if PlayOnLinux is included in the CentOS repositories, if they aren't check online on how to get that installed.

But if your exe goes too far into the hardware level it will probably not work. Besides that, network tools which yours seems to be, often also need .net, which also isn't a linux thing. There is mono which tries to give you .net functionality, but that may also have to be installed.
0
serialbandCommented:
Wine has come a long way and works ok for many single package Windows EXEs that don't rely on too many other Windows executables or frameworks, like SQL or .NET.  There are problems with losing keyboard or other random freezes in some packages.

You can look up the Wine Application Database to see if your program is supported.  https://appdb.winehq.org/  I don't see your Application on the list, but if you do get it working, you should help update it.
0
gheistCommented:
Windows program (with wine or codeweavers) will not capture Linux screen
I's guess you must inquire with airlive on how to stream output from vlc to their display (you can rig it to capture screen and stream over netwokr)
0
gheistCommented:
It is different stuff...
Airlive network cards have drivers for very old Linux kernels, and run with new kernels right away.
Here we have overhead projector with only access being "WPS.EXE"
0
NIYIOKEAuthor Commented:
Sorry guys for delaying response. When wine command did not work. and i was in a hurry to get the job done i had to use teamviewer from a Windows PC and projected from windows PC.

Thank you all for all your replies.
0
rindiCommented:
Wine needs some configuration, and it won't work with all Windows software. Teamviewer is probably a good workaround (although that in fact also runs under wine on Linux PC's.
0
gheistCommented:
Least damaging Wine is here:
https://fedoraproject.org/wiki/EPEL
Normally one runs
$ wine WPS.exe

If it does not run console output somewhat hints you need some MS frameworks installed (subject to full MS windows licence on that Linux machine)
0
NIYIOKEAuthor Commented:
wine worked. i had to yum install wine. then it worked.
0
gheistCommented:
You can tell it to airlive, maybe they send a free tshirt or pencil to you ;)
As much as here - split as you fir between 1st mention of WINE, and if it is of value that of EPEL....
0
NIYIOKEAuthor Commented:
I used Teamviewer from Windows instead of running the air live app.
0
NIYIOKEAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for NIYIOKE's comment #a40920015

for the following reason:

well, many other solutions could have worked but I just wanted another way around it.
0
gheistCommented:
I see you confirmed valid solution http:#a40885313
Electing for other solution 2 months after does not invalidate it.
0
gheistCommented:
http:#40859391 should get biggest slice, others fixing up WINE may split the rest.
0
serialbandCommented:
It does seem that he solved it with TeamViewer, then tested wine 2 weeks later.  So his selected answer is valid.
0
gheistCommented:
He did not ask for remote desktop access....
0
rindiCommented:
I agree, he asked how to run an exe program, and for that you need wine, which was suggested in the 2nd comment of the thread...
1
serialbandCommented:
He ran it in the remote TeamViewer desktop.
0
gheistCommented:
I load ggogle in my bowser and now I run google datacenter on my pc?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.