X1 Carbon not booting in Windows 8

I have a user with a Lenovo X1 Carbon running Windows 8 Pro (Latest version and updates). The last two weeks almost every other day when he comes in it will just boot to a solid blue screen and just sit there. Today after manually rebooting it a couple of times I just went into the bios, didn't select anything but just hit F10 for save and rebooted. It booted up properly. We are concerned that when he takes the laptop on the road that this may happen and he will be unable to use the device. What could be causing this issue?
Lamarr SullivanAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

diperspCommented:
Any number of issues.  Most likely hardware though.  Go to the Lenovo support site and get the diagnostics tools if they're not already loaded and have a go at them.  Not sure what generation you have, but here's for the latest generation -

http://support.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-x-series-laptops/thinkpad-x1-carbon-20bs-20bt

I'd grab them all if applicable.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
McKnifeCommented:
Mobile users should never depend on their devices that much that their mission cannot be accomplished without. That said, you have options:
-exchange the hardware and reinstall it to a working state
-provide the user with a portable "windows to go" installation that he could boot anywhere if his machine fails
diperspCommented:
Any reason for the B grade?  If the answer wasn't what you expected/needed, please clarify before grading so we can offer another response.
Lamarr SullivanAuthor Commented:
Problem is solved. I used the solution given by dipersp. I ran the diagnostics tool because I had assumed it was a hardware related issue also. While the tool did not show an issue with the dock it was the only thing left to troubleshoot .This led me to update the drivers on the USB 3.0 hub the user was using. In listening to him I found the issue only occurred in the office and never in an un-docked situation. After updating the drivers the issue has been resolved.
diperspCommented:
Then if my solution helped in the end, I would have expected an A grade.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 8

From novice to tech pro — start learning today.