Windows 2012 DCOMCNFG Service Greyed Out

Windows 2012 R2 Standard 64 bit

Trying to modify the Launch and Activation Permissions on  IIS Admin Service Properties

When I go to the Properties page the items are greyed out.

I went in the registry to change ownership from trusted installer to the local administrators group of this server.

I used these procedures

1. Run Regedit.exe and browse to "HKEY_CLASSES_ROOT\AppID\{61738644-F196-11D0-9953-00C04FD919C1}" key.
2. Secondary-mouse click on the {61738644-F196-11D0-9953-00C04FD919C1} key and select Permissions...
3. Click the Advanced button in the Permissions window and select the Owner tab. Under Change owner to select the local Administrators group and click on Apply, then OK.
4. Then under Permissions window, select the local Administrators group and under Permissions for Administrators select Full Control and click on Apply, then OK.
NOTE: DO NOT modify/change any permissions for the TrustedInstaller account.
5. Re-run the Component Services management console (dcomcnfg.exe) and you should now be able to modify the settings for IIS WAMREG admin service package.

7.Use the following steps to grant the AX Business Connector Proxy User account the Launch and Activation rights

a. Expand Component Services, expand Computers, expand My Computer, and expand DCOM Config.
b. Right-click IIS WAMREG admin Service, and then click Properties.
c. Click the Security tab.
d. Under Launch and Activation Permissions, click Edit.
e. Under Group or user names section, add the Business Connector Proxy User account, and select the user account
f. Under Permissions for the Business Connector Proxy User account, select the Local Launch and Local Activation checkboxes
g. Click OK and OK and close the Component Services management console.

Found those in this
http://blogs.msdn.com/b/emeadaxsupport/archive/2010/01/26/unable-to-edit-the-dcom-settings-for-iis-wamreg-admin-service-on-a-windows-server-2008-r2-when-trying-to-configure-kerberos-authentication-for-role-centers.aspx

I am trying to add WSS_WPG and WSS_ADMIN_WPG  groups

I have done this same procedure in the past on this same server for other SharePoint 2010 permissions.

What am I missing here?


Thanks

tom
LVL 23
Thomas GrassiSystems AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Radhakrishnan RSenior Technical LeadCommented:
Hi,

After you posting this question, I just has a look at my one of the 2012 R2 and yes it's greayed out here as well. It's greyed out for all the DCOM componenets!

The only way i can edit the security of  Launch and activation is from "My Computer" properties of the dcomcnfg. Only thing is the permission will be applicable for whole components.

Looks like it's default behavior.
0
Thomas GrassiSystems AdministratorAuthor Commented:
Hi

First thing thanks for responding

But I have be able to make changes to other components

Why is IIS Admin Service a problem?  We need to add groups for SharePoint

I give the My Computer Properties a go to see if it helps

Will post results
0
Thomas GrassiSystems AdministratorAuthor Commented:
Hello

I found this

http://social.technet.microsoft.com/wiki/contents/articles/6820.sharepoint-2010-resolving-event-id-10016.aspx

It is on a Windows 2008 R2 server  but I am on a Windows 2012 R2 server

What can we do to modify this

Thoughts
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Radhakrishnan RSenior Technical LeadCommented:
Hi,

I have a test network here, I'll replicate and let you know in few minutes :)
0
Thomas GrassiSystems AdministratorAuthor Commented:
Hi

Thanks

Standing by
0
Radhakrishnan RSenior Technical LeadCommented:
I have changed the ownership (It was Trusted installer) and added administrators group with full control. Unfortunately still the IIS admin service showing as greyed out in dcom components.

May be it may need a reboot. I'll reboot and see it makes any difference.

PS - i have changed the CLSID as required (different for IISAdmin)
0
Thomas GrassiSystems AdministratorAuthor Commented:
Yes I had the exact same thing

I rebooted yesterday after making the change and no luck

Standing by for your results
0
Radhakrishnan RSenior Technical LeadCommented:
Rebooted but still grayed out. I'll dig into this deeper and let you know if i found anything useful.
0
Thomas GrassiSystems AdministratorAuthor Commented:
Great thanks
0
Radhakrishnan RSenior Technical LeadCommented:
Hi,

I have fixed the IIS Admin service dcomcnfg security issue on the server. This is the step i have performed;

1) Open dcomcnfg>>Locate IIS Admin service>>Properties>>In the General tab we can find the CLSID, in my case it was {A9E69610-B80D-11D0-B9B9-00A0C922E750}.

2) Go to registry>>HKEY_CLASSES_ROOT\CLSID>>Right click and find the {A9E69610-B80D-11D0-B9B9-00A0C922E750}

3) Once the search completed, it will stay in the IIS Admin service CLSID folder (left hand side)>>Right click>>Permission>>Advanced>>Change the owner to administrators group>>Select the administrator>>Edit and give Full control>>Click OK and close.

Again in the same CLSID registry>>press F3 (to search again), it will show another entry for the same CLSID, you need to set the permission here as well. In my case, the CLSID were showing in 3 places and I had set the permission for all of these.

Rebooted the server and found that i was able to modify the security permission in DCOM components.

Hope this helps.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Thomas GrassiSystems AdministratorAuthor Commented:
Hi

Followed the procedure and found IIS Admin Service several times

Made the some change to all places I found

Restarted DCOMCNFG and was able to updated the Security items no longer greyed out.

Funny how they have that one in many places in the registry.


Thanks for your help
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.