Cannot delete multiple files named " ._ "

I have many sub-folders with a single file inside named " ._ " . These files cannot be deleted in Windows Explorer nor via DOS-Shell. Every attempt fails with a few different error messages, but always the same messages.
This share, and sub-folder structure, was used exclusively by MAC devices running on OS/X 10.4 + higher. I found that the Marketing department was taking too much storage so I migrated all their files to a separate server and was unable to move/ copy almost 400gigs of data due to these files due to the mass copy failing when it got to these files. After a long time manually deleting what I could not move I am now stuck with these remaining files.  

In Explorer:
The file location cannot be found when attempting to delete, rename, or otherwise modify the file directly. Windows barks stating to verify the location and try again. I can physically see the file " ._ " in the folder and the type of file is 'file'.

In DOS-Shell:
- del/ del *.*: does not see the file
- attrib -h: states the target for the symbolic link cannot be found
- rmlink: not a valid command
- rd: If used to remove the directory it fails stating the directory is not empty
- rmdir (with or without a folder path): fails stating the directory cannot be found
- dir /x: will show the hex name (varies) but a common name seen is ' 99A4~1 '. Attempting to use the hex name fails the same as every other method to modify or delete it.
- This all occurs whether I use the standard windows name or the Hex name (via dir /x)
- I can cut the parent folder and paste elsewhere via explorer. I cannot rename the actual file though, in any manner.

I see many posts about this file being a Symbolic Link, which makes sense because the MAC Users would create symbolic links to work with their documents. I'm not sure how that all works but they state they do that.

Please share your thoughts - this has been a nuisance for well over a year.
LVL 14
Michael MachieFull-time technical multi-taskerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Matt KmetyEnterprise Application AdministratorCommented:
Have you tried the following from the command line within the directory containing the files?

del /s /q /f /a:h ._.*

Open in new window


The above will target hidden files.

Below will target non-hidden files:

del /s /q /f ._.*

Open in new window

0
Michael MachieFull-time technical multi-taskerAuthor Commented:
Sorry for the long delay... for some reason I am not able to submit comments via my cell phone or the EE App and I have been away from a PC for a few days.

I have tried your suggestions and all fail. I receive the same messages I did before. To make things clearer I will snap some screenies and post them.

Update to follow.
0
Dave BaldwinFixer of ProblemsCommented:
When I had a similar problem years ago, I was able to use a Linux Live disk, either Ubuntu or Knoppix, to get rid of the files.  In my case they were put there by a virus or a trojan.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Michael MachieFull-time technical multi-taskerAuthor Commented:
Sorry for the delay - again, I am unable to post to this section from my cell phone via the EE app or the web page. Perhaps I should open a question on that? lol

Anyway, I spun up a Fedora, Mint, and Ubuntu machines and accessed the share directly. All attempts to delete the file using sudo commands and the file explorer have resulted in similar failure messages and inability to delete the files. I used both local admin and domain admin credentials to access the share.

Any other thoughts aside from a format?
0
Dave BaldwinFixer of ProblemsCommented:
I was suggesting that you boot the machine with that file with a Linux Live disk so that the Windows file permissions are not active.  As long as Windows is running, you probably won't be able to get rid of that file.  Accessing it as a 'share' leaves the Windows file interface in control.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Michael MachieFull-time technical multi-taskerAuthor Commented:
Yea, that will be the next step and I will need to wait for a maint. window. This is actually a VM on a VMWare host so is pretty easy to accomplish remotely.

This site keeps barking at me saying the question has been abandoned after 3 days so I'm not sure if the Mods will leave it open long enough for me to actually perform this task. So, I agree with you, I will need to boot off knoppix or something and try to delete. I'll mark yours as the answer because I figured I would need to do that anyway.

Thanks.
0
Dave BaldwinFixer of ProblemsCommented:
You're welcome.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.