No Wireless Internet Access from Phone, but Internet Access from laptop

Having a weird issue.  I have a Linksys WRT 1900AC.   I am able to connect to the wireless network on this router via my laptop and browse the web.  From any mobile phone, I am able to connect to the wireless network but CANNOT browse the web.

I've tried connecting from multiple phones and they all display the same behavior.
I've connected from multiple laptops and they all work.

from the phone, I am able to ping my firewall, my default gateway and other devices inside my network.  I cannot ping out from my phone, although I can ping out from the laptops that are connected to the wireless network.

My network looks like this:

Wireless Router ---->  L3 Switch ---> Firewall
10.1.1.6              -----> 10.1.1.2 (default gw) --->  10.1.1.1.

I've disabled DHCP on my wireless router, so an internal server is handing out IP addresses.  I've confirmed that I'm getting the right IP address from the server.

Any ideas as to what can be going on?
Simplegrid TechnologyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
are you also getting the correct gateway? The gateway is the key as that is what the router does is for items outside of your netmask
0
nader alkahtaniNetwork EngineerCommented:
You may use proxy
0
JohnBusiness Consultant (Owner)Commented:
Go to Settings and Turn ON Airplane mode. Wait 1 minute. Turn it OFF. This does a DNS flush for the phone. Does it get internet now?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Simplegrid TechnologyAuthor Commented:
I don't see an option for the default GW on the phone, it only shows the IP address and subnet mask (which are correct).

I'll try using airplane mode and report back.
0
David Johnson, CD, MVPOwnerCommented:
airplane mode turns off ALL networking (disables all radio's cellular and WIFI)
0
JohnBusiness Consultant (Owner)Commented:
Yes, but OFF, wait, ON turns everything back on and flushes DNS which was the reason for suggesting this.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.