Avatar of raymann77
raymann77
 asked on

Exchange 2010 Version Confusion

I updated my 2010 Exchange to SP3.  The server is a VM so I took a snapshot before hand. The install failed (sorry I dont have error message ) and after reboot Exchange was not functioning correctly. I reverted back to the snap shot before the SP3 and everything came back up.

This is where it gets strange.  I have since tried to update SP and I get error messages stating this update does not apply.

When I look under installed updates it only shows RU 5 for SP1.

EMC shows 14.3(Build 123.4)

Exsetup.exe details shows 14.0.726.0

It appears that I actually have SP1 RU 5 but Exchange thinks I have SP3.  I can also tell I dont have a new SP because I am missing the newer powershell cmds that came with later SPs.

I need to get this Exchange server updated so please help!

Thanks in advance.
Exchange

Avatar of undefined
Last Comment
raymann77

8/22/2022 - Mon
Nick Rhode

I know when you install exchange you do get prompt to update.  Otherwise what I would do is download SP3 update and install it.

The update is located here: Exchange SP3

Just a direct link to the update from Microsoft's site
Amit

Snapshot? You should never take any snapshot for Exchange server. Shutdown this server immediately. Bring that server, where you installed SP3 and tell me the error. We need to fix that server only, if not fixed, we need to reinstall it with recover switch. Note down this again in your books, never ever take snapshot for Exchange server.
raymann77

ASKER
Snapshot? You should never take any snapshot for Exchange server. Shutdown this server immediately. Bring that server, where you installed SP3 and tell me the error. We need to fix that server only, if not fixed, we need to reinstall it with recover switch. Note down this again in your books, never ever take snapshot for Exchange server.

I didnt know not to use snapshot! I cant shut that server down, its live and has been working for weeks.  Once I reverted back to pre-SP3 install I dont have access to the failed SP3 copy so I dont know what the error message is.  

Do I have other options before recover switch?

Thanks
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
Amit

You cannot roll back to older service pack. As, with new service pack you extend the schema and hence you cannot revert back to SP1.
raymann77

ASKER
But I dont think I have the SP installed.  Only EMC shows the new SP but all other indicators show no SP has been installed.  I also dont have any functionality that comes with SP3.
Amit

Can you post me the schema version Refer:
https://technet.microsoft.com/en-us/library/jj937132(v=exchg.141).aspx

If it is showing schema version as 14734. That means  your schema is extended to SP3 and there is no roll back for schema change.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
raymann77

ASKER
rangeUpper - 14734 :(

So what are my options now?

Thanks again for your help!
ASKER CERTIFIED SOLUTION
Amit

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
raymann77

ASKER
I am not familiar with recover switch.  Could I spin off a new VM, install exchange and migrate mailboxes and roles to new server?  Or would recover switch be easier?