Exchange 2010 Version Confusion

raymann77
raymann77 used Ask the Experts™
on
I updated my 2010 Exchange to SP3.  The server is a VM so I took a snapshot before hand. The install failed (sorry I dont have error message ) and after reboot Exchange was not functioning correctly. I reverted back to the snap shot before the SP3 and everything came back up.

This is where it gets strange.  I have since tried to update SP and I get error messages stating this update does not apply.

When I look under installed updates it only shows RU 5 for SP1.

EMC shows 14.3(Build 123.4)

Exsetup.exe details shows 14.0.726.0

It appears that I actually have SP1 RU 5 but Exchange thinks I have SP3.  I can also tell I dont have a new SP because I am missing the newer powershell cmds that came with later SPs.

I need to get this Exchange server updated so please help!

Thanks in advance.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Nick RhodeIT Director
Top Expert 2013

Commented:
I know when you install exchange you do get prompt to update.  Otherwise what I would do is download SP3 update and install it.

The update is located here: Exchange SP3

Just a direct link to the update from Microsoft's site
AmitIT Architect
Distinguished Expert 2017

Commented:
Snapshot? You should never take any snapshot for Exchange server. Shutdown this server immediately. Bring that server, where you installed SP3 and tell me the error. We need to fix that server only, if not fixed, we need to reinstall it with recover switch. Note down this again in your books, never ever take snapshot for Exchange server.

Author

Commented:
Snapshot? You should never take any snapshot for Exchange server. Shutdown this server immediately. Bring that server, where you installed SP3 and tell me the error. We need to fix that server only, if not fixed, we need to reinstall it with recover switch. Note down this again in your books, never ever take snapshot for Exchange server.

I didnt know not to use snapshot! I cant shut that server down, its live and has been working for weeks.  Once I reverted back to pre-SP3 install I dont have access to the failed SP3 copy so I dont know what the error message is.  

Do I have other options before recover switch?

Thanks
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

AmitIT Architect
Distinguished Expert 2017

Commented:
You cannot roll back to older service pack. As, with new service pack you extend the schema and hence you cannot revert back to SP1.

Author

Commented:
But I dont think I have the SP installed.  Only EMC shows the new SP but all other indicators show no SP has been installed.  I also dont have any functionality that comes with SP3.
AmitIT Architect
Distinguished Expert 2017

Commented:
Can you post me the schema version Refer:
https://technet.microsoft.com/en-us/library/jj937132(v=exchg.141).aspx

If it is showing schema version as 14734. That means  your schema is extended to SP3 and there is no roll back for schema change.

Author

Commented:
rangeUpper - 14734 :(

So what are my options now?

Thanks again for your help!
IT Architect
Distinguished Expert 2017
Commented:
Only option is to fix or install current server with SP3 with a recover switch.

Author

Commented:
I am not familiar with recover switch.  Could I spin off a new VM, install exchange and migrate mailboxes and roles to new server?  Or would recover switch be easier?

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial